Opened 7 years ago

Last modified 7 years ago

#478 closed defect

OSGeo4W 32bit: dumpbin failed on libintl-8.dll — at Version 1

Reported by: rashadkm Owned by: osgeo4w-dev@…
Priority: minor Component: Package
Version: Keywords:
Cc:

Description (last modified by jef)

dumpbin C:/OSGeo4W/bin/libintl-8.dll failed

I am getting the following error when building an NSIS package with OSGeo4W dependencies. This was caught by cmake when trying to get the dependencies.

CMake Error at C:/CMake-3.4.1/share/cmake-3.4/Modules/GetPrerequisites.cmake:798 (message):
  C:/Program Files (x86)/Microsoft Visual Studio 10.0/VC/bin/dumpbin.exe
  failed: 1000
  Microsoft (R) COFF/PE Dumper Version 10.00.30319.01
  Copyright (C) Microsoft Corporation.  All rights reserved.
  Dump of file C:/OSGeo4W/bin/libintl-8.dll
  File Type: DLL
  LINK : fatal error LNK1000: Internal error during DumpSections
    Version 10.00.30319.01
    ExceptionCode            = C0000005
    ExceptionFlags           = 00000000
    ExceptionAddress         = 00147F10 (00120000) "C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\bin\link.exe"
    NumberParameters         = 00000002
    ExceptionInformation[ 0] = 00000000
    ExceptionInformation[ 1] = 00000004

  CONTEXT:
    Eax    = 40000040  Esp    = 003DE1E8
    Ebx    = 014281E0  Ebp    = 003DE210
    Ecx    = 00000004  Esi    = 00000004
    Edx    = 00124164  Edi    = 0000014C
    Eip    = 00147F10  EFlags = 00010246
    SegCs  = 00000023  SegDs  = 0000002B
    SegSs  = 0000002B  SegEs  = 0000002B
    SegFs  = 00000053  SegGs  = 0000002B
    Dr0    = 00000000  Dr3    = 00000000
    Dr1    = 00000000  Dr6    = 00000000
    Dr2    = 00000000  Dr7    = 00000000

Call Stack (most recent call first):
  C:/CMake-3.4.1/share/cmake-3.4/Modules/GetPrerequisites.cmake:925 (get_prerequisites)
  C:/CMake-3.4.1/share/cmake-3.4/Modules/GetPrerequisites.cmake:925 (get_prerequisites)
  C:/CMake-3.4.1/share/cmake-3.4/Modules/GetPrerequisites.cmake:925 (get_prerequisites)
  C:/CMake-3.4.1/share/cmake-3.4/Modules/BundleUtilities.cmake:555 (get_prerequisites)
  C:/CMake-3.4.1/share/cmake-3.4/Modules/BundleUtilities.cmake:804 (get_bundle_keys)
  Code/Application/Mapla/cmake_install.cmake:119 (fixup_bundle)
  Code/Application/cmake_install.cmake:32 (include)
  Code/cmake_install.cmake:33 (include)
  cmake_install.cmake:39 (include)

Change History (1)

comment:1 by jef, 7 years ago

Description: modified (diff)
Priority: blockerminor

Maybe because libintl-8.dll is built with gcc?

Note: See TracTickets for help on using tickets.