Opened 7 years ago

Closed 14 months ago

#456 closed defect (fixed)

libmysql needs upgrade to 5.1.25+

Reported by: naihil Owned by: osgeo4w-dev@…
Priority: major Component: Package
Version: Keywords: libmysql mysql
Cc:

Description

Current libmysql (5.0.18) dont work with prepared statements on mysql servers 5.1.25+. When you bind values to prepared query, you get error "Using unsupported buffer type...". According to the docs:

"In MySQL 5.1.25, a change was made to the way that the server handles prepared statements. This affects prepared statements processed at the SQL level (using the PREPARE statement) and those processed using the binary client/server protocol (using the mysql_stmt_prepare() C API function).

An incompatibility with previous versions of MySQL is that a prepared statement may now return a different set of columns or different column types from one execution to the next. For example, if the prepared statement is SELECT * FROM t1, altering t1 to contain a different number of columns causes the next execution to return a number of columns different from the previous execution.

Older versions of the client library cannot handle this change in behavior. For applications that use prepared statements with the new server, an upgrade to the new client library is strongly recommended."

http://dev.mysql.com/doc/refman/5.1/en/upgrading-from-previous-series.html

Change History (1)

comment:1 by jef, 14 months ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.