Opened 5 years ago

Closed 5 years ago

#445 closed defect (worksforme)

QGIS 2.6 doesn't install (crssync and qgis-bin missing msvc210.dll)

Reported by: saultdon Owned by: osgeo4w-dev@…
Priority: major Component: Installer
Version: Keywords: qgis msvcrt crssync
Cc:

Description

During installation on Windows 8.1 (64bit), when the qgis-common.bat is run during postinstall crssync.exe crashes because of a missing dll and then afterwards, qgis-bin.exe complains about the missing dll as well.

I was able to get it installed without error when manually installing msvcrt2013. Does it need to be added as a dependency for QGIS 2.6?

Change History (3)

comment:1 Changed 5 years ago by macho

Same here on Windows7 Pro with MSVCP120.dll

comment:2 Changed 5 years ago by hobu

I think this was my fault. I updated libspatialindex 1.8.5, but compiled it with MSVC 2013. I neglected to note the msvc2013 dependency in setup.hint.

I have updated this and regenerated. Please test and confirm if things are ok.

Howard

comment:3 Changed 5 years ago by macho

Resolution: worksforme
Status: newclosed

Hi! Uninstalled the msvc2013 manually - uninstalled QGIS - did a reinstall and ..

Works! First dependancy now it msvc2013 (at least on my windows7) so I assume it's correct for all others as well.

thanks Werner

Note: See TracTickets for help on using tickets.