Opened 13 years ago

Closed 13 years ago

#44 closed defect (fixed)

Gdal/Proj problems with Grass installation

Reported by: cnielsen Owned by: osgeo4w-dev@…
Priority: major Component: Installer
Version: Keywords: grass, qgis
Cc:

Description

Several errors come up when starting grass, and it seems they relate to gdal and proj. Starting grass in text mode, g.region -p gives error:

"This application has failed to start because gdal16.dll was not found. Re-installing the application may fix this problem"

The same error occurs with the test version 6.4.0RC3.

For related errors in tcltk mode see: http://lists.osgeo.org/pipermail/grass-windows/2009-January/001658.html

The file gdal16.dll is not located anywhere within the OSGeo4W directory.

Change History (3)

comment:1 Changed 13 years ago by cnielsen

Keywords: qgis added

The same error occurs when starting Q-GIS.

comment:2 Changed 13 years ago by zirneklitis

Similar problems arises due to placement of installation directory. I have placed the copy of installation CD on my network server. The installation from e.g.
server\install\OSGeo4W\CD_20090127\setup.exe results in missing libraries. Mapping network drive (F:\OSGeo4W\CD_20090127\setup.exe) does not improve the situation. Only subst command solve the problem (subst G: F:\OSGeo4W\CD_20090127\). I suppose, burning CD must be also solution.

comment:3 Changed 13 years ago by cnielsen

Resolution: fixed
Status: newclosed

Update: the non-test version grass-6.4.0RC3-2 seems to have resolved this issue. There were still several packages I had to add manually including: curl, expat, hdf, libjpeg, libmysql, netcdf, ogdi, and xerces.

QGIS seems also to have been fixed, at least for that library. But an QtCore4 error came up instead. (QtCore4.dll is installed).

Note: See TracTickets for help on using tickets.