Opened 13 years ago

Closed 13 years ago

#41 closed defect (fixed)

gdal16.dll not found

Reported by: cnielsen Owned by: osgeo4w-dev@…
Priority: minor Component: Installer
Version: Keywords:
Cc:

Description

I'm using the installer from http://download.osgeo.org/osgeo4w/osgeo4w-setup.exe on winxp64 and trying to install Grass. However, when I select advanced-> desktop-> grass 6.4.0RC2-1 it does not check its dependencies for installation.

Change History (4)

comment:1 Changed 13 years ago by neteler

Can you please try again? Some dependencies have been added in 6.4.0RC2-2 (more in the works for RC3).

comment:2 Changed 13 years ago by cnielsen

Summary: Installer does not automatically select Grass dependenciesgdal16.dll not found

Trying again with 6.4.0RC2-2 adds several dependencies including gdal-16. However, several errors come up when starting grass, and it seems they relate to gdal. Starting grass in text mode, g.region -p gives error: "This application has failed to start because gdal16.dll was not found. Re-installing the application may fix this problem" The same error occurs with the test version 6.4.0RC3. The file gdal16.dll is not located anywhere within the OSGeo4W directory.

Should I start a new ticket?

comment:3 Changed 13 years ago by warmerdam

I have tried to reproduce this on an essentially clean win32 machine and requesting only the grass-6.4.0RC3-1 package. I did not observe problems with missing subpackages.

I'm wondering if this is somehow a win64 problem, though it *seems* unlikely.

I started grass from the icon, and it has the following PATH environment variable:

GRASS 6.4.0RC3 (spearfish):C:\ >path
PATH=C:\OSGeo4W/apps/grass/grass-6.4.0RC3\bin;C:\OSGeo4W/apps/grass/grass-6.4.0R
C3\lib;C:\OSGeo4W\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:
\Program Files\FME;C:\Program Files\QuickTime\QTSystem\;C:\OSGeo4W\apps\msys\bin

comment:4 Changed 13 years ago by cnielsen

Resolution: fixed
Status: newclosed

Fixed as of grass-6.4.0RC3-2

Note: See TracTickets for help on using tickets.