Opened 9 years ago

Closed 9 years ago

#382 closed defect (fixed)

gdal 1.10 bundled with 64 bit QGIS is missing deflate compression for geotiff

Reported by: drstrip Owned by: osgeo4w-dev@…
Priority: major Component: Package
Version: Keywords: gdal geotiff compression
Cc:

Description

qgis fails when attempting to load deflate compressed geotiffs. The problem traces back to the bundled gdal installed with QGIS, which fails to recognize deflate compression. The current release build of gdal on gisinternals.com successfully can read/write deflate compression, so the problem appears to lie in the build parameters of the OSGEO4W packaging. I suspect the problem may lie in the build of the tiff lib, rather than gdal itself.

Change History (4)

comment:1 by jef, 9 years ago

Can you verify the problem with GDAL from OSGeo4W? The standalone installer in not (yet) current.

comment:2 by drstrip, 9 years ago

I downloaded the full 64bit OSGEO4W package. gdal in this download appears to support COMPRESS=DEFLATE. However, the QGIS standalone installed must be using a different gdal build, because COMPRESS doesn't work there.

comment:3 by gfleming, 9 years ago

I can confirm this issue is with the standalone 64-bit installer. The OSGeo4W installer 64-bit QGIS works fine with deflate compressed tiffs.

comment:4 by jef, 9 years ago

Resolution: fixed
Status: newclosed

As said the standalone installer is not up-to-date yet.

Note: See TracTickets for help on using tickets.