Opened 10 years ago

Closed 17 months ago

#325 closed defect (outdated)

update mapserver/mapscript package to 6.2.0 (and cleanup?)

Reported by: brushtyler Owned by: osgeo4w-dev@…
Priority: major Component: Package
Version: Keywords: mapserver, mapscript
Cc: dmorissette

Description

In this moment there are a lots of different mapserver/mapscript versions shipped with OSGeo4W, most of them are old or release candidates.

The package listing shows that part is a mess:

mapscript-dev-python, 5.2b3-1
mapscript-java, 5.0.2-1
mapscript-python, 5.0.2-1
mapserv_demo, 5.0-1
mapserver, 5.2.2-2
mapserver-dev, 5.2rc1-1
mapserver-tutorial, 5.6-10
mapserver56, 5.6.6-1
mapserver6, 6.2rc1-3

We should think to remove any of them and just add the newest stable mapserver 6.2.0, in addition with its mapscript-python package.

Change History (9)

comment:1 by dmorissette, 10 years ago

Cc: dmorissette added

I'd add that the versions listed at http://trac.osgeo.org/osgeo4w/wiki/PackageListing#MapServer also need updating as the current state can be confusing to users.

comment:2 by brushtyler, 10 years ago

Who's the maintainer (providing there's one)?

It would be good if we could just drop the executables/libraries from mapserver.org, though I guess it's not possible.

comment:3 by jef, 10 years ago

I think the packages were done by jmckenna (our new president) by repackaging ms4w builds (including apache).

comment:4 by aboudreault, 10 years ago

I've made the current 6.2 package in osgeo4w.... and would to do the upgrade... but currently I can't. It's in my high priority list. It will be done as soon as possible.

comment:5 by brushtyler, 9 years ago

It seems that mapserver v6.2-rc1 was already replaced by the stable mapserver v6.2.0 in Jan 28, 2013, although the ticket wasn't updated...

I've built mapserver6.2.0 + python-mapscript6.2.0. Since the mapserver package is already updated, I would upload the python-mapscript one only. I'm testing it using the mapserver shipped with OSGeo4W.

in reply to:  5 comment:6 by brushtyler, 9 years ago

Replying to brushtyler:

I'm testing it using the mapserver shipped with OSGeo4W.

Unfortunately my python-mapscript doesn't work with the mapserver6.2.0 from OSGeo4W. I can import mapscript from python, it seems to work fine until I execute few statements, then it crashes somewhere...

Who built the current mapserver package? Could he build the python-mapscript as well?

in reply to:  4 comment:7 by dr, 9 years ago

Replying to aboudreault:

Any progress?

comment:8 by jef, 5 years ago

Oh well, then Tamas came, added 6.4.1 packages, even ran mapserver nightlies for a while - but is long gone again. I just "updated" the mapserver package to include a copy of zlib_osgeo.dll but named zlib1.dll, because I noticed that the 32bit mapscript-python packages wouldn't work otherwise (note that the previous 6.4.1-3 was from 2014).

comment:9 by jef, 17 months ago

Resolution: outdated
Status: newclosed
Note: See TracTickets for help on using tickets.