Opened 10 years ago

Closed 9 years ago

#323 closed enhancement (fixed)

Update spatialite.dll to the newest 4.0

Reported by: aperi2007 Owned by: brushtyler
Priority: major Component: Package
Version: Keywords:
Cc:

Description

Hi, actually in osgeo4w is compiled the 3.x version of the library spatialite. This deny the use of the newest format spatialite 4.0.

Please notice that in the qgis the sptailite provider was updated to support the newest format. But to fully support it is necessary to update the dll to the last version of splite 4.0

Change History (8)

comment:1 by aperi2007, 10 years ago

correlated to this update is also necessary to update the sqlite dll to the last release 3.7.15

comment:2 by jef, 10 years ago

Owner: changed from osgeo4w-dev@… to brushtyler

comment:3 by aperi2007, 10 years ago

Hi,

I produce a package with the spatialite-4.0.0.

it is downloadable from here: http://tinyurl.com/bh246rg

Using VC2008 32 bit and the defaults settings.

geos-advanced, proj, freexl In the package I remove the static library because the previous 3.0.1 package was without it.

Compiling this version , I have not add the two new options: liblwgeom and geos-trunk because this two libraries are not available actually in the osgeo4w package.

So there are not availables some new function.

However this package is absolutely mandatory to be able to read the new DB created from spatialite 4.0 on qgis.

Please notice that QGIS has already the new spatialite provider to be able to support the new SL4.0, but still don't read correctly because in the osgeo4w is missing the new spatialite.dll of SL4.0. This package will resolve this missing.

Regards.

comment:4 by rouault, 10 years ago

I'd advise waiting for GDAL 1.10 before updating spatialite to 4.0, since spatialite 4.0 support in GDAL comes with GDAL 1.10

comment:5 by aperi2007, 10 years ago

Perhaps a good mix could be to maintain on the osgeo4w the old package SL 3.0.1 to do happy gdal 1.9.x and also put the SL 4.0 to do happy the qgis SL provider ?

I don0t know if this is a realistic solution. I see only there is some package in more than one version (like gdal) so perhaps this could be done. Please notice that if is true that only gdal 1.10 is good for SL4.0. The question to maintain the SL3 will be still live if the osgeo4w will maintain the gdal 1.9 (as seem to do) version.

in reply to:  4 comment:6 by aperi2007, 10 years ago

Replying to rouault:

I'd advise waiting for GDAL 1.10 before updating spatialite to 4.0, since spatialite

4.0 support in GDAL comes with GDAL 1.10

Ok,

So I unserstand that the prefer option is to wait for the release of gdal 1.10.

To follow this strategy, I guess is better to wait also for the new spatialite 4.1. Instead of use this (when gdal 1.10 will be released) old spatialite 4.0 release.

The spatialite 4.1 will be also more compliant to the geopackage specs, and so is surely better it than this.

Furieri is working on the spatialite 4.1 just now and I guess it will arrive quite early.

So, tonight I remove the package of spatialite 4.0.

Regards,

Andrea.

comment:7 by billywill, 9 years ago

With the new qgis 64 bit exp , I am getting the error on opening qgis desktop, spatialite4.dll is missing. Can I workaround this in the short term?

comment:8 by jef, 9 years ago

Resolution: fixed
Status: newclosed

meanwhile updated to 4.1.1

Note: See TracTickets for help on using tickets.