Opened 9 years ago

Closed 8 years ago

#321 closed defect (fixed)

help needed installation of osgeo4w installer on Windows 8

Reported by: uppsruthi Owned by: osgeo4w-dev@…
Priority: critical Component: Installer
Version: Keywords: win8
Cc:

Description

I am trying to install Gdal using osgeo4w in my windows 8 operating system .Its resulting in some FATAL error i.e some :file url is not supporting but here i must give a note that i already installed QGIS and Grass so i removed them and tried again but still it throws the same exception when i am able to install them both why the whole package is not getting installed help me out in installing them.

Attachments (1)

mount - access is denied.png (1.3 KB) - added by flavour 9 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 9 years ago by maphew

Keywords: win8 added
Summary: help needed installation of osgeo4w installerhelp needed installation of osgeo4w installer on Windows 8

Hi uppsruthi,

What exactly is the error message?

Try pressing [Ctrl-C] when the dialog is active and then [Ctrl-V] in the edit box here or in Notepad. Sometimes that will copy the text of the error (at least it does on Windows XP/Vista/7). If that doesn't work take a screen shot [Alt-PrintScreen?] and attach or upload to somewhere like http://imgur.com.

I don't know how many of us have access to Windows 8, it may just be that it is just not yet supported.

comment:2 Changed 9 years ago by jef

Resolution: invalid
Status: newclosed

closing for the lack of feedback

comment:3 Changed 9 years ago by flavour

Resolution: invalid
Status: closedreopened

I get an error when trying to use the osgeo4w instaklkler on Windows 8 (was fine on my previous Windows 7). Error box has a window title of "Mount" & content of "Access is denied". I am running with full Admin rights and have disabled the UAC. (This is doing an express Desktop for any of QGIS/GDAL/GRASS) Screenshot attached.

Changed 9 years ago by flavour

comment:4 in reply to:  3 Changed 9 years ago by saultdon

Replying to flavour:

Error box has a window title of "Mount" & content of "Access is denied". I am running with full Admin rights and have disabled the UAC.

I'll test out the installer tonight, I have a Win8 laptop to try it on.

I found that Windows8 does something different with the user permissions on installed programs. Lots of applications in "Program Files" had the Users permissions set to read only. I had to allow Users write/full control rights so that files could be updated.

If I couldn't update the permissions, then running the application as an Administrator worked fine too.

On Windows 8, from the Metro menu (those ugly tiles for the touchscreen you might not have) you can right click the application tile and then at the bottom, the orange menu pops up and then select Run/Launch? as administrator from there.

I found having my user in the Administrators group didn't help at all either.

comment:5 Changed 9 years ago by flavour

'Run As Administrator' worked for me. So something has indeed changed here as I never needed to use that before when logged-in as Administrator. Anyway, this is a simple documentation fix then - ideally with a test to check for Windows 8 & being run not in that mode...although I've no idea how hard that would be to implement.

comment:6 Changed 9 years ago by cybersea

I actually had the same problem trying to install on Windows 7. I received the Mount "Access is denied" error box and the install aborted.

My windows 7 user has full administrator rights. Fortunately, right-clicking on osgeo4w-setup.exe and selecting Run as administrator worked for me.

comment:7 Changed 8 years ago by jef

Resolution: fixed
Status: reopenedclosed
Type: taskdefect

the installer was meanwhile changed.

Note: See TracTickets for help on using tickets.