Opened 10 years ago

Closed 10 years ago

#286 closed defect (fixed)

The procedure entry point not found sqlite3..

Reported by: mgala Owned by: osgeo4w-dev@…
Priority: critical Component: Package
Version: Keywords: QGIS
Cc:

Description

After upgrading today whole OSGeo4W package, (QGIS, libraries, etc.) I have critical error message: "The procedure entry point not found sqlite3_rtree_geometry_callback in sqlite3.dll" while starting QGIS (stable or dev) OS: Windows XP, latest SP & updates.

Change History (3)

comment:1 by brushtyler, 10 years ago

I'm unable to reproduce it. Does it still occur with the latest version?

comment:2 by warmerdam, 10 years ago

It at least one roughly similar case the problem was an older sqlite3.dll living in the windows system directory. The user had to replace it manually with our sqlite3.dll from C:\OSGeo4W\bin. This affected QGIS, but not (for instance) gdalinfo since QGIS does not run from he C:\OSGeo4W\bin directory.

One potential solution would be to repackage a custom sqlite3 dll with a different name. This strategy has been used for a few other common low level libraries. But it would be a substantial effort to get right and make future upgrades hard (because we couldn't use binaries provided by the sqlite project).

comment:3 by jef, 10 years ago

Resolution: fixed
Status: newclosed

qgis-dev is running from OSGeo4W/bin.

Note: See TracTickets for help on using tickets.