Opened 10 years ago

Closed 10 years ago

#281 closed defect (fixed)

apt upgrade error "ValueError: list.remove(x): x not in list"

Reported by: maphew Owned by: maphew
Priority: major Component: Package
Version: Keywords: pkg-apt
Cc:

Description

encountered when upgrading from qgis 1.7.4-3 to 1.7.4-4:

B:\o4w>"C:\Windows\regedit" /s "B:\o4w\apps\qgis\bin\qgis.reg"
Traceback (most recent call last):
  File "<string>", line 1043, in <module>
  File "<string>", line 326, in upgrade
  File "<string>", line 150, in install
  File "<string>", line 179, in install_next
  File "<string>", line 434, in do_install
  File "<string>", line 805, in post_install
ValueError: list.remove(x): x not in list

Change History (3)

comment:1 by maphew, 10 years ago

Status: newassigned

Found the cause: the current qgis package uses a leading ./ in the archive path whereas the usual method is not have a prefix at all, e.g. apps/qgis rather than ./apps/qgis.

Since from a path handling point of view both are valid, and should point to the same place, I guess this is a bug in apt (especially since setup.exe seems okay with it).

Installation is actually very nearly complete. excepting the step of renaming qgis.bat to qgis.bat.done in the installed files manifest.

To finish the install manually:

  • open etc/setup/qgis.lst.gz and change ./etc/postinstall/qgis.bat to ./etc/postinstall/qgis.bat.done
  • edit etc/setup/installed.db and add qgis qgis-1.7.4-4.tar.bz2 0

(Hmmm, there's another new ticket here. Apt doesn't roll back to initial state on a botched install attempt.)

comment:2 by maphew, 10 years ago

(In [1184]) apt.py: addresses #281

comment:3 by maphew, 10 years ago

Resolution: fixed
Status: assignedclosed

Believed fixed in r1192: strip leading dot-slash before looking for filename in install manifest.

Please reopen if needed.

Note: See TracTickets for help on using tickets.