Opened 11 years ago

Closed 14 months ago

#240 closed defect (outdated)

listgeo from libgeotiff 1.3.0-3 broken on XP

Reported by: alexbruy Owned by: osgeo4w-dev@…
Priority: major Component: Package
Version: Keywords: listgeo, libgeotiff
Cc:

Description

Just found that listgeo installed with OSGeo4W don't work. When I try to run it from OSGeo4W shell I get errors (see screenshots).

Windows XP SP3, libgeotiff-1.3.0-3

Attachments (2)

error1z.jpg (34.6 KB ) - added by alexbruy 11 years ago.
First error
error2z.jpg (28.0 KB ) - added by alexbruy 11 years ago.
Second error

Download all attachments as: .zip

Change History (5)

by alexbruy, 11 years ago

Attachment: error1z.jpg added

First error

by alexbruy, 11 years ago

Attachment: error2z.jpg added

Second error

comment:1 by maphew, 11 years ago

Summary: listgeo don't worklistgeo from libgeotiff 1.3.0-3 broken on XP

Listgeo from libgeotiff-1.3.0-3 works for me on Win7-x64, but I get the same runtime error on XP-x64.

libgeotiff-1.2.5-2 on XP works.

comment:2 by rouault, 11 years ago

AFAIR, libgeotiff 1.2 and 1.3 have different ABI, so you cannot simply update libgeotiff 1.2 -> 1.3 without recompiling packages that dependant on it and updating them too ! The fact that it seems to work on some platforms is only chance.

comment:3 by jef, 14 months ago

Resolution: outdated
Status: newclosed
Note: See TracTickets for help on using tickets.