Opened 3 years ago

Last modified 2 months ago

#952 reopened defect

Sphinx make duplicates image files

Reported by: wildintellect Owned by: live-demo@…
Priority: normal Milestone: OSGeoLive9.0
Component: LiveDVD Keywords: sphinx, docs
Cc:

Description

Sphinx appears to be duplicating each image for each translation. So we end up with 8 copies of every screenshot, for ~400MB too much.

Look in /var/www/_images/ on a recent 6.0 beta iso.

Change History (22)

comment:1 Changed 3 years ago by wildintellect

related to ticket:950

comment:2 Changed 3 years ago by hamish

  • Keywords 6.0 added
  • Priority changed from normal to blocker

comment:3 Changed 3 years ago by hamish

see http://osdir.com/ml/sphinx-dev/2012-02/msg00006.html

Jake wrote:

It seems to be a problem with sphinx not being willing to overwrite an
image file, even when the new file is identical to the one being
overwritten. Currently, we have a hack in place which, on each build,
selectively removes the files that are causing the problem. This is
not an ideal solution: any help with this would be appreciated! Thank
you
Jake Vanderplas
scikit-learn dev team

Hamish

(argh, trac keeps logging me out)

comment:4 Changed 3 years ago by hamish

here's a better thread view:

http://groups.google.com/group/sphinx-dev/browse_thread/thread/289358d8f506649b

and the relevant ticket. it was supposed to be fixed in sphinx 1.0.8, but we are using 1.3.3. ?!

https://bitbucket.org/birkenfeld/sphinx/issue/704

(perhaps the python patch there is worth trying)

Hamish

comment:5 follow-up: Changed 3 years ago by hamish

The nightly build on Adhoc does not have this bug (it's using 1.0.8+dfsg-2~bpo60+1 from Deb/Squeeze?), but I do notice this line at the end of http://adhoc.osgeo.osuosl.org/livedvd/logs/nightly_build.err

WARNING: html_static_path entry './svn/doc/_static' does not exist

maybe relevant?

Hamish

comment:6 Changed 3 years ago by hamish

work-around now implemented in install_main_docs.sh, /var/www/_images/ is down to 46mb and ~/gisvm/doc/_build/ is make cleaned away..

it's ugly though, duplicate files are replaced with symlinks to the originals. better to fix it in sphinx's python code. alternatively I added some commented out code to 'sed -i' the filenames in the .html docs dirs to match the base image name, if anyone wants to try to get that working (still a little more to do before it works).

Hamish

comment:7 in reply to: ↑ 5 Changed 3 years ago by hamish

Replying to hamish:

The nightly build on Adhoc

(I've now made it the hourly build by the way)

Hamish

comment:8 Changed 3 years ago by kalxas

  • Priority changed from blocker to normal

In latest build8234 the _images folder is 45MB. No doc duplicates.

I will keep this around until it is confirmed in beta4

comment:9 Changed 3 years ago by hamish

the bug should be kept open until it is fixed, the current work-around just alleviates the symptoms, it doesn't actually address the real problem. it's no longer a critical problem though. It also confirms that either the hardlinking by fslint is failing for the iso build, or that the remastersys max size calc is failing to account for hardlinks not taking up any (significant) extra space. If it is the latter, perhaps we can hack it to not trigger the max size check and just confirm it is not too big by hand.

thanks, Hamish

comment:10 follow-up: Changed 3 years ago by kalxas

  • Milestone changed from OSGeoLive6.0RC1 to OSGeoLive6.5

this does not affect current beta5. I am leaving it open as requested but moving it to next version

comment:11 in reply to: ↑ 10 Changed 3 years ago by hamish

Replying to kalxas:

this does not affect current beta5.

actually it very much does, but since we've mitigated the problem with an ugly hack it's no longer a blocker.

Hamish

comment:12 Changed 3 years ago by camerons

  • Keywords 6.5 added; 6.0 removed

comment:13 Changed 3 years ago by kalxas

  • Keywords 7.0 added; 6.5 removed
  • Milestone changed from OSGeoLive6.5 to OSGeoLive7.0

no problem with 6.5 release...

comment:14 Changed 2 years ago by kalxas

As long as we stay on LTS, I don't see sphinx getting an update. The bug is resolved upstream.

comment:15 Changed 2 years ago by hamish

  • Milestone changed from OSGeoLive7.0 to OSGeoLive7.5
  • Resolution set to wontfix
  • Status changed from new to closed

7.0 is keeping with 12.04, hoping it is fixed in some future version. reopen if that doesn't happen after we upgrade sphinx.

comment:16 Changed 14 months ago by hamish

  • Keywords docs added; 7.0 removed
  • Milestone changed from OSGeoLive7.9 to OSGeoLive8.0
  • Resolution wontfix deleted
  • Status changed from closed to reopened

nope, still busted in ubu 14.04 & sphinx 1.2.2.

Hamish

comment:17 Changed 12 months ago by hamish

  • Milestone changed from OSGeoLive8.0 to OSGeoLive8.5

comment:18 Changed 7 months ago by kalxas

There was a reply from Sphinx developers on GitHub?:

_From Takayuki Shimizukawa on 2014-06-11 11:17:31+00:00_

Hamish, @kalxas, I can't reproduce the behavior this issue mentioned.

If you mean that sphinx should share the image directory for each build output, I think it's a new proposal.

Please make another ticket. Or, your contribution is always welcome 


---
Reply to this email directly or view it on GitHub:
https://github.com/sphinx-doc/testing/issues/704#issuecomment-68318498

comment:19 Changed 7 months ago by kalxas

Unfortunately the repository was deleted from GitHub? and all tickets were lost...

comment:21 Changed 5 months ago by kalxas

  • Milestone changed from OSGeoLive8.5 to OSGeoLive9.0

comment:22 Changed 2 months ago by johanvdw

The correct issue for sphinx is: https://github.com/sphinx-doc/sphinx/issues/1112 I believe.

Note: See TracTickets for help on using tickets.