Opened 8 months ago

Closed 5 months ago

Last modified 5 months ago

#2997 closed task (fixed)

create email accounts for foss4g-europe

Reported by: astrid_emde Owned by: robe
Priority: normal Milestone: Sysadmin Contract 2023-I
Component: SysAdmin Keywords:
Cc:

Description

Is it possible to create email accounts for foss4g-europe?

It would be good not to have a redirect but a real email account and an online login. The email(s) could be reused every year from the local teams.

info@…

Optional, if more then on email account would make sende

  • Registration: register@…
  • Sponsor questions: sponsors@…
  • Call for papers: callforpapers@…
  • Academic papers: academic@…

Change History (28)

comment:1 by robe, 8 months ago

Milestone: UnplannedSysadmin Contract 2023-II

comment:2 by robe, 8 months ago

Milestone: Sysadmin Contract 2023-IISysadmin Contract 2023-I
Owner: changed from sac@… to robe

I think if we want real email addresses, the easiest might be to setup a GMail domain account for foss4g-europe.org.

I can get the ball rolling on this and have treasurer put in credit card for payment once I have it setup up. The current cost for a starter account I think is $6/user account. So if you just need one account info@… with 4 aliases, then it would be just $6.

In order to move forward with it, we'll need to get the approval from the Board for the $6/month monthly expense.

comment:3 by astrid_emde, 8 months ago

Hello @robe, one account is fine so we take info@...

Thanks a lot

comment:4 by astrid_emde, 7 months ago

Hello @robe is there any update on this? It would be great to get the account soon. Before October 27 would be great as the webside for the event shall go online.

Can we get the approval of the board by then?

Last edited 7 months ago by astrid_emde (previous) (diff)

comment:5 by astrid_emde, 7 months ago

Hello @robe. Shall I add the topic to the agenda of the board meeting? https://wiki.osgeo.org/wiki/Board_Meeting_2023-10-31

comment:6 by robe, 7 months ago

Yes. I just added it. Feel free to reword.

comment:7 by strk, 7 months ago

Right now OSGeo does not have a "submission" service (MSA), see https://en.wikipedia.org/wiki/Message_submission_agent

The software we use for incoming mail (MTA) can also be used for MSA so it's just a matter of deciding if we want to set that up and make it availabile to which group.

I guess by "email account" you also want IMAP access, so one option would be to install "dovecot" which is capable of doing both submission (MSA) and IMAP for reading email.

Dovecot also allows to use external database for user management, in case we don't want to provide the service to ALL OSGeo users (there are a lot) but just to a subset or to a completely different set.

comment:8 by cvvergara, 7 months ago

@robe This topic was taken on the last board meeting,

Confirm please: $6/month monthly expense for one account

then we set the aliases.

comment:9 by robe, 7 months ago

Yes this is the plan - https://workspace.google.com/pricing.html

This is the plan I am proposing:


Business Starter $6 USD per user / month, 1 year commitment

  • Custom and secure business email

  • 100 participant video meetings

  • 30 GB pooled storage per user*

  • Security and management controls
  • Standard Support

That's the same plan I have purchased before and as I recall you can have as many aliases as you want per mailbox and I think even group aliases or a catchall like *@foss4g-europe.org

Although looking at this closer, we don't own the domain foss4g-europe.org (not listed in PAIRs). We've always had things under europe.foss4g.org. Does someone else own foss4g-europe, or is that a typo in this ticket?

I've never tried setting up a gmail for a subdomain, so not quite sure it's possible.

comment:10 by cvvergara, 7 months ago

Maybe @astrid-emde knows who owns foss4g-europe.org

comment:11 by Ariel Anthieni, 7 months ago

@cvvergara Has no owner, is free in Domain, Is for sale

comment:12 by robe, 7 months ago

FWIW just checked purchasing via PAIRS foss4g-europe.org will cost us $11 for 1 year

foss4g-europe.info is $3, guess cause info isn't popular

comment:13 by astrid_emde, 7 months ago

Hello all,

we have the new website at https://2024.europe.foss4g.org/

we are fine with that address.

  • so we do not need a separate domain foss4g-europe.org
  • and we would be fine with the email info-europe@…

Does that help?

comment:14 by robe, 7 months ago

Well the only reason for separate domain was to make the gmail part more manageable cause those we need to give up a full domain. But let me think about this more.

Perhaps we should have foss4g.org use a gmail business starter since this does come up quite often for foss4g.org conferences

comment:15 by jsanz, 7 months ago

I don't know if you already considered this but Google has a free plan for non profits we could leverage for cases like this?

https://www.google.com/nonprofits/offerings/workspace/

in reply to:  15 comment:16 by robe, 7 months ago

Replying to jsanz:

I don't know if you already considered this but Google has a free plan for non profits we could leverage for cases like this?

https://www.google.com/nonprofits/offerings/workspace/

hadn't thought about that so thanks for bringing it up. Though I wonder if we qualify. We had hoped to fall in the non-profit when Microsoft looked like they'd be offering stuff up to us for free, but turned out we did not meet the qualifications for Microsoft. So I suspect it would be the same story for Google.

I forget why. I think it might have been our org type not being a 501(c)(3) so not tax exempt for donations. i forget which kind of 501(c) we are maybe 6. But whatever it is is not the you're clear "Non-profit organization"

If we are talking about just foss4g.org (which I imagine would just be 3 addresses, maybe we should just pay, cause google gives us way way more than that in real money for google summer of code), feels only fitting we should give some of that back to them.

comment:17 by astrid_emde, 6 months ago

Hello @robe,

is there any update on the ticket?

We are fine with just one email info-europe@…

comment:18 by robe, 6 months ago

No update. I'll bring it up for discussion on SAC. I think strk and others were configuring for mail so don't want to derail that.

in reply to:  17 comment:19 by robe, 6 months ago

Replying to astrid_emde:

Hello @robe,

is there any update on the ticket?

We are fine with just one email info-europe@…

Can I just put in a mail redirect for this for now. Since you are using a domain we use, foss4g.org, it's more complicated to set up a google org for that without messing up other stuff.

comment:20 by astrid_emde, 6 months ago

ok @robe. so a redirect is fine for now.

comment:21 by astrid_emde, 6 months ago

  • please redirect to contact-foss4ge@…

comment:22 by jsanz, 6 months ago

So to understand the request. This is for info-europe@… to forward incoming messages to contact-foss4ge@….

That contact-foss4ge@… is already a functioning alias which is redirecting to tonis.kardi@… and evelyn.uuemaa@…, and we should also add merli.ilves@… there as well, right?

comment:23 by robe, 6 months ago

@astrid_emde and jsanz sorry for delay in responding.

Looking at pairsdomain foss4g.org we have quite a few aliases, which I assume are no longer needed

I've added info-europe@… -> contact-foss4ge@…

I've removed the englesystem ones. foss4g2022 ones @foss4g one catchall that was set to go to info.foss4g2023@…

There are some other 2023 ones which I'm hesitant to remove until we have a 2024 replacement for those.

comment:24 by robe, 6 months ago

I forgot to mention you should get a confirmation at contact-foss4ge@… which requires approval for the forward to take effect.

comment:25 by robe, 6 months ago

Okay after my experience setting up incoming mail for discourse.osgeo.org, I have confirmed that hosting a subdomain does work for receiving mail without impacting the overall domain.

With that said, if I set up a europe.foss4g.org mail domain, and have that hosted on say Zohomail as suggested on SAC mails, it won't impact the regular foss4g. https://www.zoho.com/mail/zohomail-pricing.html

We can have a mailboxes there. Is everyone okay with that idea.

We can have contact@… which will be a real mailbox allowing send and reply?

Would that work better for everyone involved? If so I can start setting that up.

comment:26 by astrid_emde, 5 months ago

Hello @robe, thanks for all the effort.

We discussed again and are fine with the forwarding at the moment for this year. Like this we can separate each year better I guess.

We would like to ask you for one change. Could you please do the redirect to tartufoss4g@… instead of ontact-foss4ge@…. Like this we can make each year independent.

Thanks a lot

comment:27 by robe, 5 months ago

Resolution: fixed
Status: newclosed

Done so info-europe@… => tartufoss4g@… and removed contact-foss4ge@… and closing this out. Feel free to reopen if you need anything else

comment:28 by astrid_emde, 5 months ago

hello @robe, looke like everything is fine. Thanks for your support.

Last edited 5 months ago by astrid_emde (previous) (diff)
Note: See TracTickets for help on using tickets.