Opened 3 years ago

Closed 3 weeks ago

#2599 closed task (fixed)

Unable to edit wiki pages

Reported by: vasile Owned by: sac@…
Priority: normal Milestone: Sysadmin Contract 2024-I
Component: SysAdmin/Wiki Keywords: wiki
Cc: hexmode

Description

Hi there. I know I'm not the only one to complain about wiki editing after merging the accounts. I'm getting the following error when I try to edit an existing wiki page

"You do not have permission to edit this page, for the following reason:

The action you have requested is limited to users in one of the groups: Users, emailconfirmed."

Thanks, Vasile

Change History (61)

comment:1 by robe, 3 years ago

Vasile,

Please try now. I'll send a not to discuss to have others with the same issue just add to this ticket.

Thanks, Regina

comment:2 by robe, 3 years ago

Milestone: UnplannedSysadmin Contract 2021-II

comment:3 by vasile, 3 years ago

Hi Regina!

It is working. Thank you!

-Vasile

comment:4 by tadams, 3 years ago

Hi, I also have issues logging in into the WIKI. It says:

"There are problems with some of your input." "Invalid password, please try again"

Any ideas? Thanks!

My login name is "Till Adams"

comment:5 by cvvergara, 3 years ago

Hi Till, I think the problem with you is the space on your login. Will confirm with Regina.

comment:6 by robe, 3 years ago

Till -- yah yours is a special case as there is a:

109 Wiki-Till Adams
5490 Wiki-Till adams 

I need to merge those first but not sure which to keep - which one you are being forced into

comment:7 by robe, 3 years ago

Till,

Can you give it another try. I merged the Wiki-Till adams -> Wiki-Till Adams and kept the Wiki-Till Adams

As it seemed most of the information was tied to the older account. If you still have issues logging into Till Adams, let me know. I might need to reset the password or something else.

comment:8 by olivermay, 3 years ago

I also have an issue editing pages after merging the accounts. User:Olivermay

Cheers,

Oliver

comment:9 by cvvergara, 3 years ago

@olivermay Please try again. and report your success or failure

in reply to:  9 comment:10 by Olivermay, 3 years ago

It works now, thanks a lot!

Replying to cvvergara:

@olivermay Please try again. and report your success or failure

comment:11 by micheletobias, 3 years ago

I went through the process of merging my wiki and LDAP accounts but when I log in to the wiki, I have no option to edit a page. My user name is micheletobias

comment:12 by wildintellect, 3 years ago

Apparently I don't have a working account either, was pretty sure I checked after migration, and I'm not in any of the stuck in migration groups...

comment:13 by robe, 3 years ago

Can you both try. I fixed both wildintellect and micheletobias. Though I didn't see any extra permissions on your account Michele. That could be right though.

comment:14 by robe, 3 years ago

Michele looks like you had two incomplete accounts. I merged them and made you a bureaucrat.

in reply to:  14 comment:15 by micheletobias, 3 years ago

Replying to robe:

Michele looks like you had two incomplete accounts. I merged them and made you a bureaucrat.

Thanks! It works now!

comment:16 by jive, 3 years ago

I would like to be able to edit the wiki please, username jive.

comment:17 by robe, 3 years ago

Try now jive.

in reply to:  17 comment:18 by jive, 3 years ago

Replying to robe:

Try now jive.

Thanks, it is working well!

comment:19 by tadams, 3 years ago

"

Till,

Can you give it another try. I merged the Wiki-Till adams -> Wiki-Till Adams and kept the Wiki-Till Adams

As it seemed most of the information was tied to the older account. If you still have issues logging into Till Adams, let me know. I might need to reset the password or something else. "

Indeed, it does not work due to password issues. Can yiou reset the PW please ?

comment:20 by robe, 3 years ago

hmm seems the https://wiki.osgeo.org/wiki/Special:UserCredentials is not working or I am misunderstanding how it works. Still figuring out how to reset your password.

I assume you are talking about the Wiki-Till Adams one right?

comment:21 by robe, 3 years ago

Till yah something is up with the resetpassword page too. That said, I renamed your wiki account to Ghost-Till Adams.

Can you try logging in with your ldap account? Once you do that I can merge your old account back in with your LDAP account.

comment:22 by carmenTawalika, 3 years ago

Hi, I have the same problem after merging accounts. I can login with "carmenTawalika" and "CarmenTawalika" but both show the error. My id can be seen here https://id.osgeo.org/ldap/search?query=tawalika Thank you for your help.

comment:23 by robe, 3 years ago

@carmenTawalika Can you give it another try now.

comment:24 by carmenTawalika, 3 years ago

It works. That was super fast! Thank you :)

comment:25 by mmetz, 3 years ago

Same problem here: my login name is mmetz, login and migration to LDAP worked, editing wiki does not work.

comment:26 by robe, 3 years ago

@mmetz sorry for delay - try now -

comment:27 by mmetz, 3 years ago

Working now, thanks!

How about a generic solution instead of fixing each user separately?

in reply to:  27 comment:28 by robe, 3 years ago

Replying to mmetz:

Working now, thanks!

How about a generic solution instead of fixing each user separately?

We are working on one

in reply to:  20 ; comment:29 by tadams, 3 years ago

Replying to robe:

hmm seems the https://wiki.osgeo.org/wiki/Special:UserCredentials is not working or I am misunderstanding how it works. Still figuring out how to reset your password.

I assume you are talking about the Wiki-Till Adams one right?

Yes, that is right. But something changed, I now get a "LDAP login failed", I guess before I had another message ...

in reply to:  29 ; comment:30 by robe, 3 years ago

Replying to tadams:

Replying to robe:

hmm seems the https://wiki.osgeo.org/wiki/Special:UserCredentials is not working or I am misunderstanding how it works. Still figuring out how to reset your password.

I assume you are talking about the Wiki-Till Adams one right?

Yes, that is right. But something changed, I now get a "LDAP login failed", I guess before I had another message ...

Try logging in with tadams or whatever your LDAP account is. I renamed the old one to Ghost .. in hopes we could just have you create fresh and then I can merge that one into whichever one you are able to log into.

in reply to:  30 ; comment:31 by tadams, 3 years ago

Replying to robe:

Replying to tadams:

Replying to robe:

hmm seems the https://wiki.osgeo.org/wiki/Special:UserCredentials is not working or I am misunderstanding how it works. Still figuring out how to reset your password.

I assume you are talking about the Wiki-Till Adams one right?

Yes, that is right. But something changed, I now get a "LDAP login failed", I guess before I had another message ...

Try logging in with tadams or whatever your LDAP account is. I renamed the old one to Ghost .. in hopes we could just have you create fresh and then I can merge that one into whichever one you are able to log into.

Dear, finally I managed to login with "tadams" but the merge with the old wiki account "!Till Adams" failed, which is not really a problem for me. Thanks so far!

in reply to:  31 comment:32 by robe, 3 years ago

Try logging in with tadams or whatever your LDAP account is. I renamed the old one to Ghost .. in hopes we could just have you create fresh and then I can merge that one into whichever one you are able to log into.

Dear, finally I managed to login with "tadams" but the merge with the old wiki account "!Till Adams" failed, which is not really a problem for me. Thanks so far!

Till - I just merged your old data into the Tadams Ldap user and restored your rights. Can you see if all looks good now and you can edit.

comment:33 by tadams, 3 years ago

looks like everyting is there. Perfect, thanks!

comment:34 by robe, 3 years ago

For everyone still having this issue - we've put a patch in production which hopefully should fix this. I'll close this ticket out in a couple of weeks if no one else is having issue after.

comment:35 by Gérald Fenoy, 3 years ago

I do apologie but I was able to login and update to LDAP account. Nevertheless, once logged in using the LDAP user account I cannot edit any wiki page.

I hope you can help.

comment:36 by robe, 3 years ago

@djay hmm does seem like your account is still "in process of migrating" status. Before I take that switch off, can you try logging out and logging back in? I'm hoping it's just your login was cached and it didn't trigger the script changes to take effect as a result.

comment:37 by Gérald Fenoy, 3 years ago

@robe still same issue after logging out and logging back in.

comment:38 by robe, 3 years ago

djay okay I've fixed your account. Please try again.

comment:39 by pesekon2, 3 years ago

Same problem here: my login name is pesekon2, login and migration to LDAP worked, editing wiki does not work.

comment:40 by robe, 3 years ago

pesekon2 Try now.

Last edited 3 years ago by robe (previous) (diff)

comment:41 by pesekon2, 3 years ago

@robe: Works now. Thanks.

comment:42 by strk, 2 years ago

Milestone: Sysadmin Contract 2021-IISysadmin Contract 2022-I

Ticket retargeted after milestone closed

comment:43 by vrautenbach, 2 years ago

Hi Regina, I also have the same issue, unable to edit. My username is Vrautenbach. Would you be able to help or am I missing a step. Thank you in advance.

comment:44 by robe, 2 years ago

@vrauenbach,

I thought your account had been cleared already, but looks like it wasn't. Try now.

FYI to any wiki admins,

Go to this page - https://wiki.osgeo.org/wiki/Special:UserRights Type in the user name in question.

and uncheck the following groups (anybody in these groups can't edit)

  • wiki account
  • account in progress of converting

Converted users should be in at least this group:

  • merged account

comment:45 by vrautenbach, 2 years ago

@robe! Thanks, it works. Appreciate the help.

comment:46 by bencaradocdavies, 2 years ago

I am getting the same error. Wiki login and LDAP migration worked fine, but I cannot edit my wiki home page. My username is bencaradocdavies.

"You do not have permission to edit this page, for the following reason: The action you have requested is limited to users in one of the groups: Users, emailconfirmed."

comment:47 by strk, 2 years ago

Cc: hexmode added

On this page: https://wiki.osgeo.org/wiki/Special:ListUsers?username=bencaradocdavies I see listed this record:

Bencaradocdavies talk contribs block‏‎ (account in progress of converting, merged account, wiki account) (Created on 26 January 2022 at 21:47)

The account in progress of converting label is a link, but if I click on it I go to a page which lists NOBODY in that group: https://wiki.osgeo.org/wiki/MediaWiki:Wikitoldap-in-progress

It sounds like a bug to me.

I've manually removed the "account in progress of converting" and "wiki account" groups from the account, using https://wiki.osgeo.org/wiki/Special:UserRights/Bencaradocdavies - let us know if this fixed your issue.

comment:48 by bencaradocdavies, 2 years ago

Thanks @strk, wiki editing seems fixed for me. Much appreciated.

comment:49 by strk, 2 years ago

Milestone: Sysadmin Contract 2022-ISysadmin Contract 2022-II

Ticket retargeted after milestone closed

comment:50 by strk, 2 years ago

I've just had to do this again for user vmische. This might be worth filing upstream: https://www.mediawiki.org/wiki/Extension:WikiToLDAP

comment:51 by strk, 2 years ago

Keywords: wiki added

User Vmische made a great report about how the user merge broke for him: https://gist.github.com/vmx/dca37d56fda76dbd8e800110798b6b49

comment:52 by ticheler, 2 years ago

Hi,

I'm facing the exact same problem for my account with username ticheler. Thanks for helping to resolve this!

Cheers,

Jeroen

in reply to:  52 comment:53 by robe, 2 years ago

Replying to ticheler:

Hi,

I'm facing the exact same problem for my account with username ticheler. Thanks for helping to resolve this!

Cheers,

Jeroen

try now

comment:54 by kthujvu, 20 months ago

'ello! One fix for https://wiki.osgeo.org/wiki/User:Kthujvu please, thanks :)

https://wiki.osgeo.org/wiki/Special:Preferences lists "Accounts in progress of converting, Accounts that have been merged, Old wiki accounts, Autoconfirmed users, Users"

I seem to have edited the wiki with this account in 2018 https://wiki.osgeo.org/w/index.php?title=OSGeo_Code_Sprint_2018&oldid=114126 but then joined a different wiki user (Hannes) with this one. Maybe that caused some hiccup?

comment:55 by cvvergara, 20 months ago

@kthujvu can you please try again.

comment:56 by robe, 17 months ago

Milestone: Sysadmin Contract 2022-IISysadmin Contract 2023-I

pushing to next milestone since my contract funds have been used.

comment:57 by sethg, 10 months ago

Hi my user is also broken for wiki access - is this the place to request help?

My user is: https://wiki.osgeo.org/wiki/User:Sethg When logging in I get an "Internal Error" on all pages:

[2944cc5ded0c6712a6d3b2cc] /w/index.php?title=Special:LDAPUserMerge&returnto=Main_Page Error from line 536 of /var/www/wiki_osgeo/html/w/includes/htmlform/HTMLForm.php: Class 'htmlbuttonfield' not found

Backtrace:

#0 /var/www/wiki_osgeo/html/w/includes/htmlform/OOUIHTMLForm.php(51): HTMLForm::loadInputFromParameters()
#1 /var/www/wiki_osgeo/html/w/includes/htmlform/HTMLForm.php(385): OOUIHTMLForm::loadInputFromParameters()

My user rights are:

Member of: Accounts in progress of converting Implicit member of: Autoconfirmed users

https://wiki.osgeo.org/w/index.php?title=Special%3AUserRights&user=Sethg

comment:58 by neteler, 10 months ago

Hi sethg, I hope I fixed the group settings, please try again.

comment:59 by strk, 7 months ago

Component: SysAdminSysAdmin/Wiki

comment:60 by robe, 5 months ago

Milestone: Sysadmin Contract 2023-ISysadmin Contract 2024-I

Moving my prior still open items to the next proposed Milestone

comment:61 by robe, 3 weeks ago

Resolution: fixed
Status: newclosed

closing this out since we haven't had any complaints about this recently.

Note: See TracTickets for help on using tickets.