Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#2453 closed task (fixed)

can not login using LDAP to osgeo webpage

Reported by: codrina Owned by: sac@…
Priority: normal Milestone: Unplanned
Component: Systems Admin Keywords:
Cc:

Description

Hi,

I can't login using LDAP (userID codrina) to the OSGeo website. After resetting the password, it still doesn't work. The error I get is wrong credentials, however I have no problem using those to login into nextcloud, gitea or trac. I know that at some point, long ago, I could login. I did some editing before the website was public, so maybe my account was not made using LDAP.

Any help will be much appreciated.

Codrina

Change History (4)

comment:1 Changed 3 months ago by strk

Milestone: UnplannedSysadmin Contract 2020-I

If you can login into Gitea and Trac then YES, your account made it into LDAP. If Website doesn't let you, it must be a Website issue.

comment:2 Changed 3 months ago by robe

Milestone: Sysadmin Contract 2020-IUnplanned
Resolution: fixed
Status: newclosed

codrina -- your account was created locally I think and was missing the LDAP bits. I merged your ldap and local account so you should be able to log in now.

Did it from the database backend

INSERT INTO <wp prefix goes here>_usermeta(user_id, meta_key,meta_value)
VALUES (57, 'wpDirAuthFlag', 1)
 ,(57, 'wpdirauth_prnd', 1);

Please try logging in again to confirm it works, and feel free to reopen if it doesn't.

comment:3 Changed 3 months ago by strk

How could she connect to Trac and Gitea if the account was only local ?

Can we DISABLE creation of "local" accounts on the website ?

comment:4 in reply to:  2 Changed 3 months ago by codrina

Replying to robe:

Please try logging in again to confirm it works, and feel free to reopen if it doesn't.

I tried it and it works! I can now successfully login into Trac, Gitea, Nextcloud and OSGeo website. Thank you!

Note: See TracTickets for help on using tickets.