Opened 4 years ago

Closed 4 years ago

#2430 closed task (fixed)

Having some issues with lxd again with snapshots

Reported by: robe Owned by: sac@…
Priority: normal Milestone: Unplanned
Component: SysAdmin Keywords:


Secure might be down for a couple of minutes while I shuffle things arounds

Change History (5)

comment:1 by robe, 4 years ago

Issue is described here -

But only seems to be an issue with some containers. Short of rebooting the host suggested solution is below which didn't seem to work

for m in $(grep lxcfs /proc/mounts | grep proc | awk {'print $2'}); do umount ${m}; done

comment:2 by robe, 4 years ago


containers currently affected by this issue are

tracsvn, secure (I renamed this to secure2 and was able to snapshot, but can't rename it back), old-web - (renamed this to old-web2 and was able to snapshot but again can't rename cause it seems some snapshots got stock on old name), old-projects, old-webextra, old-wiki

Other containers are fine (download, grass, wordpress, nginx, dronie-server, collabora, nextcloud-ubuntu)

A reboot I think fixes this issue, but lxd 4.0.0 is coming out tomorrow, so figured I'd wait since it does a restart of lxd services anyway so might fix it too.

comment:3 by robe, 4 years ago

okay was able to rename secure back by doing this:

lxc cp secure2 secure --instance-only

Unfortunate that leaves all the old snapshots on the secure2 I had moved from

comment:4 by robe, 4 years ago

Did the same for old-webextra and old-web.

comment:5 by robe, 4 years ago

Resolution: fixed
Status: newclosed

okay it upgraded to lxd 4.0.0 but still had same issue.

This worked

lxc exec old-projects -- shutdown -P -h now
#get list of mounts
 grep default/containers/old-projects /proc/*/mountinfo
 nsenter -t 4273 -m umount  osgeo7/containers/old-projects
lxc start old-projects
lxc snapshot old-projects #works now
Note: See TracTickets for help on using tickets.