Opened 3 years ago

Closed 7 months ago

#2372 closed task (fixed)

Upgrade Trac to 1.4

Reported by: robe Owned by: sac@…
Priority: normal Milestone: Sysadmin Contract 2022-II
Component: Systems Admin Keywords:
Cc:

Description (last modified by robe)

I tried upgrading trac to latest 1.2 which is 1.2.6 on dev and ran into issues with genshi template engine, seemed it couldn't upgrade that. However upgrade to trac 1.4.2 was fine. I'm not sure how to check which plugins don't work or not easily. I confirmed the email one and LDAP one are working. The other issues people had I suspect are not relevant since most projects have moved on to github for ticket tracking.

I plan to take a final look this weekend and then complete the upgrade on production.

Change History (17)

comment:1 by robe, 3 years ago

I did a trial upgrade to 1.4 on dev and seemed to go okay

https://dev.trac.osgeo.org/osgeo

I'll check to make sure no broken plugins before I do the same to production.

comment:2 by strk, 3 years ago

What we need to ensure still works is the mapping from OSGeo Usernames to emails, for Cc/ and mailing partecipants into a ticket.

It's implemented by a plugin of our own: https://git.osgeo.org/gitea/sac/TracLDAPEmailResolverPlugin

comment:3 by robe, 3 years ago

Description: modified (diff)
Summary: Upgrade Trac to 1.4Upgrade Trac to 1.2.5

comment:4 by robe, 3 years ago

I restored latest backup of production and overwrote tracsvn-dev with it and upgraded it to 1.2.5

Please check it out. It seemed though I needed to do a dist upgrade before I could do a clean 1.2.5 ugprade (and in process things like postgresql client got upgraded to 12 (though server is still at 10)

Please check it out. https://dev.trac.osgeo.org/osgeo

comment:5 by robe, 3 years ago

Milestone: Sysadmin Contract 2019-IISysadmin Contract 2020-I

comment:6 by robe, 2 years ago

Milestone: Sysadmin Contract 2020-ISysadmin Contract 2020-II

move open times to new contract

comment:7 by robe, 2 years ago

Milestone: Sysadmin Contract 2020-IISysadmin Contract 2020-III

oops moved to wrong milestone last run

comment:8 by robe, 2 years ago

Milestone: Sysadmin Contract 2020-IIISysadmin Contract 2021-I

Milestone renamed

comment:9 by robe, 19 months ago

Milestone: Sysadmin Contract 2021-ISysadmin Contract 2021-II

Move these to next contract milestone

comment:10 by strk, 11 months ago

Milestone: Sysadmin Contract 2021-IISysadmin Contract 2022-I

Ticket retargeted after milestone closed

comment:11 by robe, 9 months ago

Milestone: Sysadmin Contract 2022-ISysadmin Contract 2022-II

comment:12 by robe, 7 months ago

Description: modified (diff)
Summary: Upgrade Trac to 1.2.5Upgrade Trac to 1.4

comment:13 by robe, 7 months ago

oops just realized latest is 1.4.3, so I'm going to test that first on dev.

comment:14 by robe, 7 months ago

I haven't deployed the new 1.4.3 to production because the layout, they introduced some widget to show wiki page in full width mode vs. collapsed. It defaults to collapsed which I find very annoying and makes all our pages look different (the wiki part) than it did before.

On the up side it did drag me into installing themes which is nice, there is a BlueFlat one which I found especially nice, but can't figure out how to get logo.

Anyway on to the annoying collapsed layout. They do have configuration under preferences - detailed here https://trac.edgewall.org/ticket/12780 that allows each user to configure to their liking.

I still would like it to default to full if users don't have it configured so we have the old look of the pages. I haven't figured out where that setting is for default state. Hopefully there is one.

comment:15 by robe, 7 months ago

The other issue that was complained about when I had upgraded earlier was lack of SectionEditPlugin. I was able to uninstall the old version 1.2 and install the new 1.3. I confirmed 1.3 works in Trac 1.4.3.

comment:16 by robe, 7 months ago

Okay I'm going to start the upgrade process on prod. I think all the plugins we had before I have gotten to work on dev. So it's just that annoying default collapse which I'll resolve after we are live.

comment:17 by robe, 7 months ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.