Opened 6 months ago

Closed 5 months ago

Last modified 5 months ago

#2315 closed task (invalid)

Make LXC containers referenceable by name by resolver

Reported by: strk Owned by: sac@…
Priority: normal Milestone:
Component: Systems Admin Keywords:
Cc:

Description

See https://blog.simos.info/how-to-use-lxd-container-hostnames-on-the-host-in-ubuntu-18-04/

It would help generalizing the ssh configuration from client to reach each and every container...

Change History (9)

comment:1 Changed 5 months ago by strk

Resolution: fixed
Status: newclosed

For the time being this is already possible from any LXC container (at least the "download" one) so I'm closing this as done, to some extent.

comment:2 Changed 5 months ago by strk

Resolution: fixed
Status: closedreopened

Re-opening, as name resolution seems to be still unstable (see #2318)

comment:3 Changed 5 months ago by robe

Resolution: fixed
Status: reopenedclosed

closing this as I think that was a fluke.

comment:4 Changed 5 months ago by strk

Resolution: fixed
Status: closedreopened

Really? This is what happens right now from download.osgeo.org:

strk@download:~$ host secure.lxd
Host secure.lxd not found: 3(NXDOMAIN)
strk@download:~$ host secure.lxc
Host secure.lxc not found: 3(NXDOMAIN)
strk@download:~$ host secure
Host secure not found: 2(SERVFAIL)

comment:5 Changed 5 months ago by robe

Resolution: invalid
Status: reopenedclosed

That's cause you have the name wrong. It's new-secure, not secure.

We can change the name of the container if it'll make you feel better.

comment:6 Changed 5 months ago by strk

It actually would :) Using old- for old and unprefixed for current would be more consistent :)

comment:7 Changed 5 months ago by robe

Done

and updated

https://git.osgeo.org/gitea/sac/osgeo7/wiki/secure

with details of the renaming.

Also changed read me to reflect the new name

now you should be able to access via secure.lxd

comment:8 Changed 5 months ago by strk

Thanks, confirmed. My .ssh/config now looks like this:

Host osgeo-*
  ProxyCommand ssh download.osgeo.org -W $(sed -e "s/^osgeo-//;s/$/.lxd/" <<< "%h"):%p

And I can successfully do:

  ssh osgeo-secure

comment:9 Changed 5 months ago by strk

NOTE: I've further updated the README with my .ssh/config block

Note: See TracTickets for help on using tickets.