Opened 12 years ago

Closed 12 years ago

#230 closed task (fixed)

Migrate vsftpd to download.osgeo.org

Reported by: warmerdam Owned by: Mateusz Łoskot
Priority: normal Milestone:
Component: Systems Admin Keywords: ftp
Cc: mlucas

Description

Mateusz,

Could you please migrate vsftpd to the new download.osgeo.org blade?

The main reason I want to do this is that it doesn't start up on machine reboot currently since /osgeo/download is an nfs mount and apparently gets mounted after the ftp service is started.

No big rush to work on this, May would be ok as long as it isn't forgotten forever.

Change History (8)

comment:1 Changed 12 years ago by mloskot

Status: newassigned

comment:2 Changed 12 years ago by mloskot

Frank,

I configured vsftpd service on the new server. It should not start automatically because I issued:

chkconfig vsftpd off

In order to start/stop/restart, following commands are available:

/etc/init.d/vsftpd start
/etc/init.d/vsftpd stop
/etc/init.d/vsftpd restart

I'm going to update Download Server wiki.

Please, check if everything works as expected.

comment:3 Changed 12 years ago by mloskot

I've forgot to add, after it's tested and confirmed as working well, I will turn the on-boot startup on.

comment:4 Changed 12 years ago by warmerdam

Cc: mlucas added

Mark,

When you get a chance, could you update the DNS records for ftp.remotesensing.org to point to 198.202.74.218, and add a note here?

Thanks!

comment:5 Changed 12 years ago by mloskot

The vsftpd daemon starts on boot now.

comment:6 Changed 12 years ago by warmerdam

Mark,

Could you update ftp.remotesensing.org to point to 198.202.74.218 and then add a note here?

Thanks,

comment:7 Changed 12 years ago by mlucas

Updated DNS for ftp.remotesensing.org to 198.202.74.218

mrl

comment:8 Changed 12 years ago by warmerdam

Resolution: fixed
Status: assignedclosed

Thanks Mark

Note: See TracTickets for help on using tickets.