Opened 8 months ago

Closed 7 months ago

#2280 closed task (fixed)

Move all sites off of projects.osgeo.osuosl.org and on to osgeo7 old-projects container

Reported by: robe Owned by: sac@…
Priority: normal Milestone: Sysadmin Contract 2019-I
Component: Systems Admin Keywords:
Cc:

Description

I checked projects.osgeo.osuosl.org

and confirmed that the following sites are still running on it.

featureserver.org might be defunct, by I think the others are still actively used.

They are

spatialreference.org (sr.org.conf)
community-review.foss4g.org
featureserver.org

I don't have root access yet to see what other stuff might be running here.

The spatialreference might be involved as it looks like it does a proxypass to another server on this box.

featureserver since to run as a cgi, so might be equally complicated to move off

community-review appears to be more or less static so can probably be moved off easily

Change History (13)

comment:1 Changed 8 months ago by wildintellect

spatialreference.org is a python based wsgi application, no need to move the apache config. I helped move this once so I can assist. I think the complication is that it might use a postgis database.

featureserver we can just try to mirror to static like the foss4g archive

comment:2 in reply to:  1 Changed 8 months ago by neteler

Replying to wildintellect:

spatialreference.org is a python based wsgi application, no need to move the apache config. I helped move this once so I can assist. I think the complication is that it might use a postgis database.

Please keep in mind that spatialreference.org is AFAIK totally outdated. So a big related disclaimer would be good. Last update: 2013!

comment:3 Changed 8 months ago by warmerdam

I'm seeing spatialreference.org as not-functioning -- I'm getting the message "We are sorry, but requested page is currently unavailable. Please try again later." at http://spatialreference.org.

GDAL uses spatialreference.org as a source of coordinate systems and potentially a lot of folks around the work depend on this (including as it happens the Planet Labs MODIS ingestors). I'd appreciate seeing spatialreference.org continue to function.

comment:4 Changed 8 months ago by wildintellect

I had no plans to retire it, I too agree that it still has use even if it doesn't get active updates. The error you found is a new thing, let's open a separate related ticket on that as it's not related to the moving which is in progress not completed.

comment:5 Changed 8 months ago by rouault

@wildintellect I might give a hand to help restoring spatialreference.org, although I would need to have at least the starting point on which machine this is installed (and the appropriate access permissions)

comment:6 Changed 8 months ago by robe

Just an update. Instead of moving things off of projects, I'm migrating projects to an lxd container using the lxd-psc tool.

Ran into some stumbling blocks mostly with fstab mounts, and the static ip.

The container apache seems to work, but the nginx which is what sr.org apparently runs under (proxied from the apache) is giving me a proxy error.

Anyway hope to have it working before end of week.

comment:7 Changed 8 months ago by jef

libdevmapper can be removed - it's apparently only used by grub.

comment:8 Changed 8 months ago by rouault

I see that spatialreference.org works again now

comment:9 Changed 8 months ago by robe

Yah sorry about the downtime. I had shut down the databases before doing a snapshot to get a clean snapshot of the VM. I haven't flipped to the new yet as I'm still sorting thru some issues. I do see it is working in the new container, but the Apache thing is a bit screwed up in that when I asked for community-review.foss4g.org - I got spatialreference.org instead (but it worked - I could navigate all the spatial ref sys). Once I have that sorted out, I'll flip to the new server and then we can fiddle with upgrading the debian OS later.

BTW I do have the ssh port open if anyone wants to check it out.

The old-projects container ssh is osgeo7.osgeo.osuosl.org -p 50025

Since it's a replica of the old, you should be able to get into it with your ldap accounts.

I'm thinking since most of this stuff is obsolete, once it's working I'll close off the ssh access, but you would still be able to ssh via the download container to it.

comment:10 Changed 8 months ago by robe

Resolution: fixed
Status: newclosed
Summary: Move all sites off of projects containerMove all sites off of projects.osgeo.osuosl.org and on to osgeo7 old-projects container

I have made live on new container - spatialreference.org / www.spatialreference.org

and community-review.foss4g.org (not sure how to test this one as all I see is a static page)

The spatialreference I took out of the apache enabled setup and just have the nginx container proxy straight to the nginx 8092 port on the old-projects container

Change the DNS on Pairs and set letsencrypt on and force redirect to ssl.

My understanding with featureserver.org is that Chris was tired of it. I haven't bothered trying to resuscitate it (its still pointing at old server). wildintellect if you want to be my guest. I had issue getting apache going as it seems to not match *: so only can serve one site and I think it's got a bunch of other baggage behind it.

We could just have it run on another port I guess since it will be proxied thru the nginx container anyway.

That said - unless anyone has any reason -- I think we can kill projects.osgeo.osuosl.org.

Last edited 8 months ago by robe (previous) (diff)

comment:11 Changed 8 months ago by robe

Oh I forgot to mention -- sr.org config had a bunch of aliases I couldn't find in our pair account. Were these ever used?

spatial-reference.org
www.spatial-reference.org
www.spatialreferences.org
spatialreferences.org

comment:12 Changed 8 months ago by robe

Resolution: fixed
Status: closedreopened

turns out community-review is still being used for foss4g2019 as I learned from Paul.

The 2019 database was created after I moved over the VM.

I sent and email to Vasile and Volker and Paul that I restored the 2019 database on the new server and I shut down apache on the projects.osgeo.osuosl.org to make sure I didn't miss anything.

I'll close this out once they confirm all is working.

I haven't remapped featureserver.org, but I guess I might as well do that for closure.

comment:13 Changed 7 months ago by robe

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.