Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#2243 closed task (fixed)

Upgrade to nextcloud latest

Reported by: robe Owned by: sac@…
Priority: normal Milestone: Sysadmin Contract 2020-I
Component: SysAdmin Keywords: nextcloud

Description (last modified by robe)

Current version is 18

We are running nextcloud 15.0.0 and came out a couple of days ago. It doesn't have that many bug fixes, but the version does have a lot of bug fixes.

I did an experimental upgrade and it will require probably about 30minutes - 1 hour of downtime.

They have an online upgrade which I tried but it timed out doing backup etc, and since we don't really need our data backed up since I can snapshot the container before upgrade, seems better to go with the manual upgrade.

I'm also thinking of moving the data folder out of nextcloud folder and have on same level

I took the defaults during install which created a path like this:


I'd like to change it to this:


Main reasons for changing it, is

1) I think it's better to not have the data in the web folder just in case their is na nginx misconfiguration and it makes that exposed.

2) During these upgrades the upgrade steps are to

mv nextcloud nextcloud-old

and then copy/move over the data folder and any 3rd party apps you may have. I would do the move since I would do a snapshot of the vm anyway before hand. I'd much rather not having to worry about moving/copying the data folder back in place.

I've taken a backup of the nextcloud image and other containers until we have the general backup routine sorted out.

Change History (22)

comment:2 by robe, 5 years ago

Milestone: Sysadmin Contract 2019-I

comment:3 by robe, 5 years ago

Summary: Upgrade to nextcloud to nextcloud 15.0.5

New version is now 15.0.5.

I'm going to do some minor updates (collabora and group folders) to the plugins for now and deal with this upgrade later.

comment:4 by robe, 5 years ago

Milestone: Sysadmin Contract 2019-ISysadmin Contract 2019-II

Moving this to contract 2

comment:5 by robe, 4 years ago

Milestone: Sysadmin Contract 2019-IISysadmin Contract 2020-I

comment:6 by robe, 4 years ago

Description: modified (diff)
Summary: Upgrade to nextcloud 15.0.5Upgrade to nextcloud latest

comment:7 by robe, 4 years ago

okay looks like we need to do 3 upgrades to go to 18 as hopping from 15 -> 18 is not supported.

I'm testing now with backup copy of the nextcloud container on osgeo4 to make sure no surprises. I'll also move the data folder in the process as it will make future upgrades easier too.

comment:8 by pcav, 4 years ago

FYI: just upgraded our NC instance (17>18). We ran into small issues, running upgrade twice solved it effectively. I'm available for help if necessary.

comment:10 by robe, 4 years ago


Yah I think they might have already fixed this issue in 18.0.3. I did a trial run of upgrading nextcloud from 15 - 18 using a backup of production system and didn't run into any issues except for 1. I did run into a blip but I think that was because I forgot to turn off the nextcloud cron job. Rerunning upgrade fix it. Anyway going to start the upgrade soon. Thanks for the input.

comment:11 by robe, 4 years ago


One question I was wondering about. Are you using the new documentserver_community extension (Only office integrated document editing).

I was experimenting with using that instead of the collabora online we are currently using for viewing/editing office / libreoffice docs, but I couldn't get it to work. Said it was installed but documents weren't editable.

I also read that it doesn't scale well and some issues with documents being saved with it, so was thinking maybe I should just stick with the collabora office online we have already. Only reason I wanted to switch is I liked the idea it was self-contained. Right now I have a collabora container set up for handling the document editing/viewing features.

comment:12 by pcav, 4 years ago

Hi @robe, we have just started experimenting. AFAICT the collaborative editing installed by default (I think it is called text) is good enough for our purposes. I'd prefer a text-based editor (.md) to a complex one (.odt or similar).

comment:13 by robe, 4 years ago

Resolution: fixed
Status: newclosed


Yah the text one is a separate. I just completed the upgrade to 18.0.3 so please give it a try and see if you run into any issues.

I did run into issue with 18 upgrade (when I ran into it on dev, I thought it was because cron was on but this time I had it off).

The error was

#got this error - Repair error: Repair step 'OCA\Talk\Migration\FixNamespaceInDatabaseTables' is unknown

So to fix I change turned off maintenance and reran again.

It succeeded but looks like it disabled the Talk plugin which I don't think we were using anyway. I haven't tried reenabling it. That looks to be a different error than what was described in the link referenced above.

comment:14 by pcav, 4 years ago

Thanks a lot. Looks pretty slow for now, but it does what it is supposed to do. We used Talk, it would not be bad to have it back, but if it's complicated don't worry.

comment:15 by robe, 4 years ago

Okay I'll try to enable it and see what happens. It did seem a little slow to me too but wasn't sure if its because I moved the data directory and its still building the database cache.

comment:16 by robe, 4 years ago

pcav I reenabled Talk app and it seemed to reenable okay. Then it wanted me to join into an old call. Not sure what that was about. Anyway give it a try and see if it still works as you expect.

comment:17 by pcav, 4 years ago

Checked, apparently it works. I did not try with several users however (none available right now). I think it's OK. Thanks again!

comment:18 by robe, 4 years ago

I also figured out why my install of document server did not work. I was missing the step of enabling the onlyoffice app. I'm going to change to the onlyoffice one from collabora online so the document management is all self-contained, no longer reliant on another container.

comment:19 by robe, 4 years ago

scratch that thought I did some tests on and it appears that onlyoffice handles MS office documents really well, but not as good as collabora online for open office. It also can't open my open office drawings (.odg files) where as collabora can. So I guess maybe I'll just upgrade collabora and keep using it, cause both can't be turned on I don't htink as they would both try to handle the same files.

comment:20 by pcav, 4 years ago

Slowness has been reported. From the mail:

It probably took me 10 times longer to make my edits than it would have in google docs. A lot of the time I would type and it would not respond, and then ten seconds later suddenly play all my keystrokes at once like in this gif (I am typing pretty much the whole time in the recording):

It also seems to be unable to allow me to double click words to highlight them. I had to also reload the page completely a few times because it just froze.

Last edited 4 years ago by pcav (previous) (diff)

comment:21 by robe, 4 years ago


Is this with co-editing?

Are we talking about .md files or office documents.

I have only office installed on if you are testing office docs, can you give that a try and see if it is any better.

The only office does seem to be a bit faster to me so debating if I should replace collabora with onlyoffice.

comment:22 by pcav, 4 years ago

co-editing odt We'll check onlyoffice. Thanks a lot.

Note: See TracTickets for help on using tickets.