Opened 13 months ago

Closed 10 months ago

Last modified 9 months ago

#2179 closed task (fixed)

Deployment of LimeSurvey on OSGeo servers

Reported by: vasile Owned by: sac@…
Priority: major Milestone:
Component: Systems Admin Keywords:
Cc: TemporSent, robe2

Description

Hi SAC members,

During the face2face meeting in Bonn, OSGeo board decided to extend the use of electronic voting system to charter members to avoid the "spam" on our mailing list. The board also decided to implement the electronic voting system on OSGeo's infrastructure (until now was hosted on various friend organizations). That being said, I would like to ask SAC to deploy a LimeSurvey? (https://www.limesurvey.org/stable-release) instance on our servers.

Thank you,

Vasile

CRO

Change History (9)

comment:1 Changed 10 months ago by wildintellect

This is a great scenario for use of a container. Can we test this on Funtoo for now while we setup OSGeo7. Elections are soon so this is somewhat urgent.

comment:2 Changed 10 months ago by vasile

I urge SAC to deploy LimeSurvey? on our infrastructure in the next 10 days. Otherwise we will not be able to use it for this year elections.

Vasile CRO 2018

comment:3 Changed 10 months ago by strk

Cc: TemporSent added

TemporSent?, any idea about setting up LimeSurvey? in an LXD container ? Otherwise we may try docker ? https://www.limesurvey.org/es/foro/news/98178-lime-survey-container-on-docker-ready-to-run

comment:4 Changed 10 months ago by TemptorSent

Cc: robe2 added

Now in process of adding lxd container for limesurvey on funtoo host container. We need to identify who will be acting as admin for this instance and determine what additional configuration may be required.

comment:5 Changed 10 months ago by vasile

CRO should be the admin person (this year is me). A crucial aspect is to configure the email in ksuch way that messages from cro@… to accounts like Yahoo or Gmail don't end-up in Spam folder.

comment:6 Changed 10 months ago by robe

vasile,

We've finished setting up limesurvey on funtoo.

I added your ldap account as an administrator

Login here: https://limesurvey.osgeo.org/admin/index.php

Please give it a try and see if it works okay for you. Make sure to use LDAP database for login.

comment:7 Changed 10 months ago by vasile

I did. Is working! Thank you so much!

comment:8 Changed 10 months ago by robe

Resolution: fixed
Status: newclosed

vasile I assume you are all set for now. Feel free to reopen if you need anything.

comment:9 Changed 9 months ago by robe

For completeness there was an issue with the mailing from limesurvey

which got carried over to here: https://git.osgeo.org/gitea/osgeo/todo/issues/20

We believe the issue is now resolved.

To resolve (quick fix, more involved fix to be implemented at our leisure would be to get authentication working) here are the steps SAC took:

1) Add the limesurvey.osgeo.org (aka funtoo.osgeo.org) IP to /etc/postfix/main.cf postfix file in osgeo6 in the mynetworks attribute - so added at end was 172.97.103.135/32

2) postfix reload # so new changes took effect

3) git add .. and commit with what was changed - this is by the way not in gitea, it's just a local standalone git it seems and there are many uncommitted files :)

4) Did some tests with nc to do a commandline email on the limesurvey.osgeo.org and cofirmed I received it.

5) On Limesurvey change the Mail to use SMTP (mail server only) no authentication since the ip has been whitelisted

6) Vicky set up a test survey and was able to send it to herself, complete and receive a confirmation notice.

Last edited 9 months ago by robe (previous) (diff)
Note: See TracTickets for help on using tickets.