Opened 4 years ago

Closed 3 years ago

#2077 closed task (fixed)

Test with PHP7

Reported by: cvvergara Owned by: webcom@…
Priority: normal Milestone: Unplanned
Component: WebSite Keywords: Test
Cc:

Description

Set up of website with PHP7 is here https://staging2.www.osgeo.org

Tests:

  • Login using ldap
  • Login using OpenID
  • Navigate the site
  • Navigate the administration site
    • Verify that the gravatar are OK
  • Add pages
  • Remove pages
  • Add Person images

Change History (9)

comment:1 Changed 4 years ago by cvvergara

Done:

  • Login using ldap
  • Navigate the site
  • Navigate the administration site
    • Verify that the gravatar are OK

comment:2 Changed 4 years ago by strk

OpenID Login fails with both "staging" (PHP6) and "staging2" (PHP7), although in different ways (PHP7 is unable to discover identity server, PHP6 ends up giving me a Forbidden message)

comment:3 Changed 4 years ago by cvvergara

Tests Done:

  • added a post
    • added a feature image (never saw it in the preview or the published page)
    • Used the SEO tool
  • Moved to trash a post (the one added)
  • Deactivated the OpenID plug in

comment:4 Changed 4 years ago by cvvergara

Tests Done:

comment:5 Changed 4 years ago by cvvergara

  • tested changing a form

comment:6 Changed 4 years ago by cvvergara

  • Tested changing time zone
  • forms email test: fields are saved
    • TODO, test that email is received

comment:7 Changed 4 years ago by robe

found something that doesn't work. The system snapshot plugin I had installed on staging.www.osgeo.org that worked there, just shows a blank screen on staging2.www.osgeo.org. I tried to uninstall and reinstall, but that didn't help.

Issue is documented here https://wordpress.org/support/topic/fatal-error-when-running-on-php7/ . It's a very old plugin and doesn't give me any info I can't easily get from shell so not super critical.

Last edited 4 years ago by robe (previous) (diff)

comment:8 Changed 4 years ago by robe

cvvergara I installed sendmail on staging2 and was able to get a test message I sent via the WP Mail Plugin.

I did the same on the staging.www.osgeo.org since that was missing sendmail as well. Let me know if you run into issues with test mail send.

comment:9 Changed 3 years ago by robe

Resolution: fixed
Status: assignedclosed

I think we are done with this have https://staging.www.osgeo.org now on web18a with PHP 7

Note: See TracTickets for help on using tickets.