Opened 7 years ago

Closed 7 years ago

#1939 closed defect (fixed)

Captcha never accepts correct answers when edited a wiki page.

Reported by: ptschrum Owned by: strk
Priority: normal Milestone:
Component: SysAdmin/Trac Keywords: Captch Wiki GRASS GSoC
Cc: neteler


I am having difficulty editing my GSoC, Grass project wiki. Specifically, when I attempt to edit my project page ( I get a captcha challenge which never accepts my input. It gives me a challenge question which is an arithmetic question in words (not numerals). When I enter the answer (whether in numerals or words), it always rejects me.

Change History (6)

comment:1 by strk, 7 years ago

Cc: neteler added
Component: WikiTrac
Owner: changed from christian, sac@… to strk

My fault if this got the wrong component, I now realize it's a trac wiki... Didn't even know there was a captcha, must be the spam filter. Any GRASS person around ?

comment:2 by strk, 7 years ago

Please next time it happens report here the time at which it is happening, so I have something to search in the logs. As reported on IRC you were able to solve other captchas, and they were all of the same kind (ExpressionCaptcha).

comment:3 by strk, 7 years ago

To recap: user reports it was first suspected of being a spammer due to "too many external links". From then on, he was always supected, but this time it was due to "IP previously blocked" (20-ip.js). So I suspect it was *us* (trac) signalling his IP to BlogSpam, because we have the "Train external services" configuration active in

In any case, BlogSpam checks (external links, reported IP) give a karma of -2 while captcha solving gives a karma of +3, so that check should not be too bad.

This ticket, anyway, is about correct captcha solutions not being accepted. When tried to be challenged again we failed (with user on IRC). The system reports captcha as solved but the user did not even see it, so there might be some sort of cached response.

comment:4 by ptschrum, 7 years ago

Just a quick note to let you know I have seen these comments and will move correspondence about the issue here.

comment:5 by strk, 7 years ago

I've no disabled the spamfilter plugin, too many false positive

comment:6 by strk, 7 years ago

Resolution: fixed
Status: newclosed

Closing as fixed, feel free to reopen if it happens again.

Note: See TracTickets for help on using tickets.