Opened 8 years ago

Closed 14 months ago

#1688 closed task (fixed)

Add libravatar support to MediaWiki

Reported by: strk Owned by: sac@…
Priority: minor Milestone:
Component: SysAdmin/Wiki Keywords: wiki, avatar
Cc:

Description

libravatar is a federated avatar service. Avatars for email are retrived by looking up the mail domain DNS.

See https://www.mediawiki.org/wiki/Extension:Libravatar

Attachments (1)

avatar_https_issue.png (35.9 KB ) - added by neteler 7 years ago.
Screenshot of broken https wiki connection

Download all attachments as: .zip

Change History (20)

comment:1 by strk, 8 years ago

Keywords: avatar added

comment:2 by strk, 8 years ago

Component: WebSiteWiki
Owner: changed from webcom@… to christian

comment:3 by strk, 7 years ago

Priority: normalminor

comment:4 by Jeff McKenna, 7 years ago

I've installed this libravatar extension. You can see it in action at the top of my profile page: https://wiki.osgeo.org/wiki/Jeff_McKenna

The syntax is:

<libravatar email="jmckenna(at)osgeo(dot)org"/>

comment:5 by strk, 7 years ago

Nice :) I wonder if we can make it automatically shown in the user table, like I did manually here: https://wiki.osgeo.org/wiki/Sandro_Santilli

comment:6 by strk, 7 years ago

Resolution: fixed
Status: newclosed

I did the automatism: https://wiki.osgeo.org/index.php?title=Template:OSGeo_Member&action=edit

Happy now, closing :)

Thank you Jeff!

comment:7 by neteler, 7 years ago

I notice that the avatar is added via http and not https, see

https://wiki.osgeo.org/wiki/Jeff_McKenna

--> media link is: http://cdn.libravatar.org/avatar/0a704ecea4b9ac81d60689bd711ae938?size=32

Like this the https connection is downgraded to http. Perhaps it needs some other setting in the Extension:Libravatar?

comment:8 by Jeff McKenna, 7 years ago

I'm not aware of such a setting.

comment:9 by strk, 7 years ago

I checked this, and found that the plugin should theoretically use HTTPS when HTTPS was used to access the page. Indeed that works for me, ie: I see an https url to the avatar of Jeff_McKenna when going to the link you posted, Markus. Can you reproduce your obtaining http instead ?

Maybe the detection happens once so if the first request was an HTTP it will stick for future requests ? I've filed the issue here anyway: https://github.com/netresearch/mediawiki-libravatar/issues/2

in reply to:  9 comment:10 by neteler, 7 years ago

Resolution: fixed
Status: closedreopened

Replying to strk:

I checked this, and found that the plugin should theoretically use HTTPS when HTTPS was used to access the page. Indeed that works for me, ie: I see an https url to the avatar of Jeff_McKenna when going to the link you posted, Markus. Can you reproduce your obtaining http instead ?

Still http, see attachment.

And, if you right-click, open-image you still get this link:

http://www.gravatar.com/avatar/0a704ecea4b9ac81d60689bd711ae938.jpg?r=g&s=32&d=http://cdn.libravatar.org/nobody/32.png

Maybe the detection happens once so if the first request was an HTTP it will stick for future requests ?

Mhh, no idea.

I've filed the issue here anyway: https://github.com/netresearch/mediawiki-libravatar/issues/2

by neteler, 7 years ago

Attachment: avatar_https_issue.png added

Screenshot of broken https wiki connection

comment:11 by strk, 7 years ago

Today I'm also getting http instead of https, this is really odd now... Can you check if you get http on my page too ? https://wiki.osgeo.org/wiki/Sandro_Santilli

I get https there.

EDIT: as the two pages were using two different tags, I changed Jeff page tag to be <Libravatar>EMAIL</Libravatar> instead of <Libravatar email="EMAIL" /> And now I get HTTPS in Jeffs page too. Does it work for you too now ?

comment:12 by strk, 7 years ago

Owner: changed from christian to sac@…
Status: reopenednew

Reassigning to SAC

in reply to:  11 comment:13 by neteler, 7 years ago

Replying to strk:

Today I'm also getting http instead of https, this is really odd now... Can you check if you get http on my page too ? https://wiki.osgeo.org/wiki/Sandro_Santilli

At time there is no avatar entry, right?

comment:14 by strk, 7 years ago

On my page avatar is the one on the top-right corner of the "OSGeo Member" tab. It's done automatically by the template, using the "Email" field (try it on your page!)

in reply to:  14 comment:15 by neteler, 7 years ago

Replying to strk:

On my page avatar is the one on the top-right corner of the "OSGeo Member" tab. It's done automatically by the template, using the "Email" field (try it on your page!)

ok got it! Yes, your's in now in https.

comment:16 by strk, 7 years ago

Mine was in https even before. What about Jeff's, do you get Jeff's in https too ?

Can you check with your page too ? My current observation is:

  • Using <Libravatar email=".." /> produces http
  • Using <Libravatar>...</Libravatar> produces https
  • Using OSGeo member form uses the <Libravatar>...</Libravatar> format

comment:17 by strk, 7 years ago

Resolution: fixed
Status: newclosed

I'm closing this, it works for me and 11 days are too much for replying :)

comment:18 by strk, 14 months ago

Resolution: fixed
Status: closedreopened

Libravatar plugin was removed because incompatible with current version of MediaWiki. We need to bring it up to speed, if we figure out how. See https://www.mediawiki.org/wiki/Extension:Libravatar

comment:19 by strk, 14 months ago

Resolution: fixed
Status: reopenedclosed

#2907 was created to deal with the replacement

Note: See TracTickets for help on using tickets.