Opened 14 years ago

Closed 14 years ago

#150 closed defect (fixed)

Mapbender Trac: no mail notification when using OSGeo accounts in "assign to" field

Reported by: christoph Owned by: warmerdam
Priority: minor Milestone:
Component: Systems Admin Keywords: trac email
Cc:

Description

AFAIK, in the early days of Mapbender Trac people received an email, when they were assigned a ticket (by entering just the OSGeo account and not email address in the "assign to" field). Nowadays, this does not seem to work anymore, an email address has to be specified.

Change History (11)

comment:1 Changed 14 years ago by christoph

Type: taskdefect

comment:2 Changed 14 years ago by warmerdam

Keywords: trac email added

I'll look into this one.

comment:3 Changed 14 years ago by warmerdam

Status: newassigned

I created a ticket in the osgeo trac and then changed the assigned to field to "osgeotest123" and the appropriate notification was sent to the corresponding email account.

Trying in mapbender trac next.

comment:4 Changed 14 years ago by warmerdam

OK, I have tried:

  • Creating a ticket, and then assigning it to an osgeo userid as a second step. Email notification sent to the new assignee successfully.
  • Created a ticket and directly entered an osgeo userid as the assignee. Email notification sent to the new assignee successfully.

So I haven't been able to reproduce the problem you are reporting. It *seems* like setting the assignee field to an osgeo userid does result in email being sent to the email address registered for that userid.

Is it possible:

  • Your osgeo email address is wrong?
  • The notifications are getting sucked up by a spam filter?
  • The problem is intermittent?

comment:5 Changed 14 years ago by christoph

Thank you for looking into it, Frank.

A problem may be that my mail address changed a while back, from @ccgis.de to @wheregroup.com. Here's what strange about it (I guess I should add a new ticket for this?):

  1. The "user account" page at osgeo.org still lists "christoph.baudson@…" as mail address; yet I receive an email sent to "christoph@…", but I do not receive an email sent to "christoph.baudson@…"
  1. When I change the mail address on the "user account" page, I am notified that the changes have been saved, yet when I hit the account page again, the old entry is still listed.

So I assume the update worked as I receive mails from osgeo.org, but I'm puzzled by not receiving mails from Trac and by the wrong entry on the account page.

comment:6 Changed 14 years ago by christoph

Frank, I will check with non-Wheregroup developers first and will let you know how that works

comment:7 Changed 14 years ago by christoph

It works for at least one non-Wheregroup member.

There are some other issues:

1) I asked Astrid (astrid_emde) to log on to osgeo.org and check her mail settings, but even logging in didn't work for her, there wasn't even an error message (but the same login works for Trac). (I was at least able to log in at OSGeo)

2) I realized that by entering an email address in Trac's "settings" dialogue, I could get the functionality back. Yet the non-Wheregroup member doesn't have to specify an email address in "settings" (that's the way I remembered it to be).

So if you don't have time to solve this, we are fine, we just need to edit the "settings" dialogue. On the other hand, I would be interested to find out what the problem is; it must have something to do with the mail address change.

comment:8 Changed 14 years ago by warmerdam

Christoph,

I'm willing to take the time to work on this problem, but I need to be able to reproduce the problem. Perhaps you could give privately email me userid/password info for an account suffering this problem. (warmerdam@…). You can use the form at https://www.osgeo.org/cgi-bin/auth/ldap_edit_user.py to reset a password to avoid giving me a password you wish to continue using afterwards.

Also, could you be specific about where astrid_emde attempted to login with OSGeo userid info unsuccessfully? Was this via the "Username: * Password: * [Log in]" box on the bottom left of the http://www.osgeo.org/ page? This *should* work with OSGeo userids.

comment:9 Changed 14 years ago by warmerdam

Christoph,

Reading back, I now think I see the problem. When the Where group folks email addresses changed, they each needed to visit:

https://www.osgeo.org/cgi-bin/auth/ldap_edit_user.py

And modify the email address listed for their account. I have confirmed that the email address for astrid_emde is still the ccgis.de address.

Note that email addresses of the form <user>@osgeo.org are handled entirely separately. They are just an /etc/aliases file manually maintained in /etc on www.osgeo.org. So if those work it is presumably because Tyler or someone did a bulk edit on it.

Could you, Astrid, etc try the above modifications and see if it resolves the situation?

comment:10 Changed 14 years ago by warmerdam

PS.

According to this search, only the astrid_emde, christoph and uli accounts still have the old address.

http://www.osgeo.org/cgi-bin/ldap_web_search.py?query=ccgis.de

comment:11 Changed 14 years ago by warmerdam

Resolution: fixed
Status: assignedclosed

i think this is all taken care of.

Note: See TracTickets for help on using tickets.