Opened 12 years ago

Closed 10 years ago

#2254 closed defect (fixed)

Response to WMS getcapabilities request version 1.1.1 asks for a projection parameter

Reported by: nsavard Owned by: dmorissette
Priority: normal Milestone: 6.0 release
Component: WMS Server Version: 5.0
Severity: normal Keywords:
Cc: tomkralidis

Description

When I issue a WMS getcapabilities request to MapServer 5.0.0-beta4 by specifying version 1.1.1 I got the following warning in the response. I have a map and a layer projection in the map file. Can someone shed some light on this?

<!-- WARNING: Mandatory mapfile parameter '(at least one of) MAP.PROJECTION, LAYER.PROJECTION or wms_srs metadata' was missing in this context. -->

The request is: QUERY_STRING="map=[MAPFILE]&SERVICE=WMS&VERSION=1.1.1& REQUEST=GetCapabilities?"

and the MapServer options are:

MapServer version 5.0.0-beta4 OUTPUT=GIF OUTPUT=PNG OUTPUT=JPEG OUTPUT=WBMP OUTPUT=SVG SUPPORTS=PROJ SUPPORTS=AGG SUPPORTS=FREETYPE SUPPORTS=WMS_SERVER SUPPORTS=WMS_CLIENT SUPPORTS=WFS_SERVER SUPPORTS=WFS_CLIENT SUPPORTS=WCS_SERVER SUPPORTS=GEOS INPUT=EPPL7 INPUT=POSTGIS INPUT=OGR INPUT=GDAL INPUT=SHAPEFILE

Change History (12)

comment:1 in reply to:  description ; Changed 12 years ago by tomkralidis

Cc: tomkralidis added

Replying to nsavard:

I just tested this against trunk, with PROJECTION defined at the MAP and LAYER level, and don't get this warning. Can you post a testcase (or is this an msautotest/wxs test)?

comment:2 in reply to:  1 Changed 12 years ago by nsavard

Replying to tomkralidis:

Replying to nsavard:

I just tested this against trunk, with PROJECTION defined at the MAP and LAYER level, and don't get this warning. Can you post a testcase (or is this an msautotest/wxs test)?

Tom,

This is a msautotest test in which I change the version 1.1.0 to 1.1.1. The test is wms_simple.map in wxs directory.

comment:3 in reply to:  1 Changed 12 years ago by nsavard

Replying to tomkralidis:

Replying to nsavard:

I just tested this against trunk, with PROJECTION defined at the MAP and LAYER level, and don't get this warning. Can you post a testcase (or is this an msautotest/wxs test)?

I should have said that I used the MapServer fgs module from fgs-msx-5.0.

comment:4 Changed 12 years ago by tomkralidis

I can reproduce this behaviour now. That's wierd. For 1.1.1 you get this warning and for 1.1.0 you don't?

comment:5 in reply to:  4 Changed 12 years ago by nsavard

Replying to tomkralidis:

I can reproduce this behaviour now. That's wierd. For 1.1.1 you get this warning and for 1.1.0 you don't?

That's exactly it. I know it's weird.

comment:6 Changed 12 years ago by tomkralidis

For some reason, you have to set LAYER/METADATA/wms_srs to remove this warning. But this doesn't happen in 1.1.0.

I'm lost on this one.

comment:7 Changed 12 years ago by dmorissette

I think this is the same issue as #2028 ... I still don't know what the source of the problem is though.

comment:8 Changed 12 years ago by dmorissette

Milestone: 5.0 release5.0.1 release
Owner: changed from mapserverbugs to dmorissette

comment:9 Changed 12 years ago by dmorissette

Milestone: 5.0.1 release5.2 release

comment:10 Changed 11 years ago by dmorissette

Milestone: 5.2 release5.4 release

comment:11 Changed 11 years ago by dmorissette

Milestone: 5.4 release6.0 release

comment:12 Changed 10 years ago by dmorissette

Resolution: fixed
Status: newclosed

This must have been the same issue as ticket #2028 which I fixed yesterday.

Closing fixed. Please reopen with a testcase if that's not fixed for you.

Note: See TracTickets for help on using tickets.