Opened 10 years ago

Closed 10 years ago

#2121 closed enhancement (fixed)

gd-rendering : draw symbols along a line using pixmap symbols

Reported by: assefa Owned by: jmckenna
Priority: normal Milestone: 5.0 release
Component: Documentation - MapServer Version:
Severity: normal Keywords:
Cc: jmckenna@…

Description

Currently for line features, when a pixmap symbol is set in a style, the pixmap is used as a brush to draw the line. If the true type fnts is used, it will draw the font along the line. The idea is to support the pixmap symbols to work like the true type fonts. Distnace bteween symbols would use the GAP parameter in the symbol. Symbols will be rotated and scale if necessary along the line.

Attachments (2)

v50.gif (214.0 KB) - added by flavio 10 years ago.
Version 5: wrong
v410.gif (99.7 KB) - added by flavio 10 years ago.
V4.10: correct

Download all attachments as: .zip

Change History (19)

comment:1 Changed 10 years ago by assefa

Owner: changed from sdlime to assefa
Status: newassigned

Commited in r6205.

Needs to update related docs before closing.

comment:2 Changed 10 years ago by assefa

Cc: jmckenna@… added

if GAP is 0 (default value), we will use the symbol as a brush like it used to work before 5.0 r6206

Migration guide updated r6207.

Adding Jeff ic cc : Jeff what are the docs that need to be updated to refltec these ? there is at least the symbolgy reference doc and the GAP parameter

comment:3 Changed 10 years ago by assefa

doc http://mapserver.gis.umn.edu/docs/reference/symbology should be updated for the GAP parameter. The update should reflect

  • that GAP is also used for pixmap symbols.
  • The text about the negative GAP should be changed : a negative gap will add 180 degress to the angle. The true type and pixmap symbols are always oriented along the line

comment:4 Changed 10 years ago by assefa

Owner: changed from assefa to jmckenna@…
Status: assignednew

comment:5 Changed 10 years ago by flavio

in previous versions, a negative GAP forced the direction of the symbol to follow the digitizing direction of the line. now, in 5.0, this seems not to work anymore. Negative GAP seems to have no effect at all to me.

comment:6 Changed 10 years ago by flavio

confirmed: attacched now some screen shots.

Changed 10 years ago by flavio

Attachment: v50.gif added

Version 5: wrong

Changed 10 years ago by flavio

Attachment: v410.gif added

V4.10: correct

comment:7 Changed 10 years ago by assefa

falvio,

  • Can you confirm that you are using a true type symbols and not a pixmap symbol ?
  • From what I can see, the 5.0 image seems to be an AGG output so It would be an AGG specific bug. Looking into the source code, there is no change AFAIK done in the gd code concerning true type symbols drawn along the line. You could maybe quickly confirm that the GD rendering works in 5.0.

Looking into the AGG code, It seems to me that there might be a problem with true type symbols darwn along the line, but I do not have a good test data immaediatly available to test this. Please let me know and if it is the case, we could enter a bug in the AGG module and correct it.

comment:8 Changed 10 years ago by flavio

hi assefa

I can confirm:

  • truetype symbols
  • no difference if I use AGG or not (i.e. simple JPEG)
  • exactly the same data and same MapFile? sections and Symbol Definitions (see below)
  • seems that with 5.0 the negative GAP is completely ignored (the 5.0 result with negative GAP looks like 4.10 with no GAP or positive GAP).

SYMBOL

NAME "Arrow1" TYPE TRUETYPE FONT "Arial" CHARACTER ">" GAP -10

END

comment:9 Changed 10 years ago by assefa

flavio this seems to have been fixed today: http://trac.osgeo.org/mapserver/changeset/6746

comment:10 in reply to:  9 Changed 10 years ago by flavio

flavio this seems to have been fixed today: http://trac.osgeo.org/mapserver/changeset/6746

GAP Value does not work 100%. If I have a GAP of -10, -20, -1000, result is always the same ... This is the case when having SIZEUNITS meters. I'd expect the GAP to be meters then (?) ... SIZEUNITS pixels seems fine.

comment:11 Changed 10 years ago by assefa

falvio,

I have not tried what you have reported but if it is a bug, It would be better to enter it as a new AGG bug (or send an e-mail on the list) and hopefully it will be adressed before the release. This discussion is reallly out of the bug 2121 and should be separted.

comment:12 in reply to:  11 Changed 10 years ago by flavio

Hi Assefa

I did that already, to me it is not an AGG bug. It is a generic bug. SIZEUNITS are not used by the Symbol Definition. See Ticket #2289.

comment:13 Changed 10 years ago by sdlime

Can someone mark this one as fixed or wontfix if indeed the original subject of this bug is no longer an issue?

Steve

comment:14 Changed 10 years ago by assefa

Steve, I left it open and assigned to to Jeff for the docs to be updated. I think when Jeff is done with the update, It will be closed.

comment:15 Changed 10 years ago by sdlime

Component: MapServer C LibraryMapServer Documentation

comment:16 Changed 10 years ago by jmckenna

Owner: changed from jmckenna@… to jmckenna
Status: newassigned

comment:17 Changed 10 years ago by jmckenna

Resolution: fixed
Status: assignedclosed

i have updated the GAP parameter for http://mapserver.gis.umn.edu/docs/reference/symbology and tested with mapserver-5.0-rc2.

Note: See TracTickets for help on using tickets.