Opened 15 years ago

Closed 15 years ago

#2029 closed defect (duplicate)

OUTLINE on LABELs.

Reported by: a.pintado@… Owned by: sdlime
Priority: lowest Milestone:
Component: MapServer CGI Version: 4.10
Severity: minor Keywords:
Cc: a.pintado@…

Description

With this 4.10 version, label OUTLINE isn't a perfect pixel arround the label. 
It seems like it tries to do the outline by moving label only at some degrees. 

I have this LAYER definition in the map file:

# *********************************

LAYER
 GROUP 'ORTO2004_TOP_OFI'
 NAME "TOPONIMIA_OFICIAL"
 TYPE ANNOTATION
 STATUS ON
 DATA "TOPONIMIA_OFICIAL/TOPONIMIA_OFICIAL"
 SIZEUNITS METERS
 LABELITEM 'TEXTSTRING'
 LABELANGLEITEM 'TEXT_ANGLE'
 LABELSIZEITEM 'TEXT_SIZE'
 CLASSITEM 'LAYER' 
 LABELMAXSCALE 50000
 LABELMINSCALE 100

 CLASS #	
	EXPRESSION	'TOP_06' # EDIFICIS 
	MAXSCALE 5000
	LABEL
	MINDISTANCE 0
	POSITION CC
	ANGLE AUTO
	TYPE TRUETYPE
	FONT "arial"
	COLOR	0	0	0
	OUTLINECOLOR 250 230 240
	END
 END

 DUMP TRUE 
  METADATA
    WMS_GROUP_TITLE "ORTO2004_TOP_OFI"
    WMS_TITLE "TOPONIMIA_OFICIAL"
    WFS_TITLE "TOPONIMIA_OFICIAL"
    WMS_ABSTRACT "metadades"
    WMS_SRS "EPSG:23031"
  END
END

# *********************************

I have 4.6 version of mapserver, and it works perfect.

Change History (1)

comment:1 by sdlime, 15 years ago

Resolution: duplicate
Status: newclosed
This is the same issue as described in bug 2027 I believe. Marking as a 
duplicate.

Steve

*** This bug has been marked as a duplicate of 2027 ***
Note: See TracTickets for help on using tickets.