Opened 13 years ago

Closed 13 years ago

#850 closed defect (wontfix)

MapGuide kml export not supported on Google Earth 4.3 and later

Reported by: msuing Owned by:
Priority: high Milestone:
Component: KML Service Version: 2.0.2
Severity: major Keywords: google earth, kml
Cc: External ID:

Description

The MapGuide kml exports doesn't seems to work since the version 4.3 of Google Earth (same result with GE 5).

When you export data to Google Earth, the information is proposed in the legend, but the objects never appear on the map.

It could be caused by the NetworkLink support or the kml version ?

Change History (6)

comment:1 by jng, 13 years ago

Version: 2.0.12.0.2

I can verify the same behaviour using MGOS 2.0.2 and Google Earth 5.0

Using the Sheboygan Dataset, my observations with the KML service are as follows:

Since GetMapKml contains Network Links to GetLayerKml calls (which contain Network Links to GetFeaturesKml calls), there must have been some breaking change with regards to Network Links since GE 4.3

comment:2 by tomfukushima, 13 years ago

Milestone: 2.1

I can't reproduce this. Can you add the URL you are using to this ticket? Also, does GE open for you automatically with the URL, or do you find that you have to do other things like first save the file; and if so what do you do?

comment:3 by jng, 13 years ago

I am using the mapagent test pages (http://localhost:8008/mapguide/mapagent/index.html)

I am invoking the KML service operations using the default values provided for those forms.

GetMapKml (w/ default values) - GE opens, zooms to extents. No features returned from MapGuide GetLayerKml (w/ default values) - GE opens, zooms to extents. No features returned from MapGuide GetFeaturesKml (w/ default values) - GE opens, zooms to extents. Features are returned from MapGuide

comment:4 by jng, 13 years ago

Ok here's some extra information.

The kml returned by MapGuide does not actually do anything in GE when it is first opened.

If you analyse the traffic in fiddler you will see dropped requests to the mapagent

However, if you make that same request again (in an open instance of GE), it will then work as normal.

If you saved that request as a kml file, the effect is identical.

Open it in GE for the first time. Nothing happens. Attempts to refresh layers will show as dropped mapagent requests in fiddler.

Open it again in GE for the second time. Things work as expected.

comment:5 by jng, 13 years ago

I just tried to consume KML from a MGOS 1.2 installation with GE 5.0 client and I get the same result.

The offender is Google Earth. Has been since 4.3

http://code.google.com/p/earth-issues/issues/detail?id=21

comment:6 by jng, 13 years ago

Resolution: wontfix
Status: newclosed

I tried this with Google Earth and it's working again.

So use Google Earth 5.1 and stay away from any release between 4.3 and 5.0

Note: See TracTickets for help on using tickets.