Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#580 closed defect (fixed)

Can't save my map

Reported by: andrewd Owned by: ksgeograf
Priority: high Milestone:
Component: Maestro Version:
Severity: critical Keywords:
Cc: External ID:

Description

When trying to make a new Map with a layer group, I get an error when I try to save. The error is "(559)MgDbXmlException". This happens whether or not there's anything actually IN the group.

Change History (5)

comment:1 by andrewd, 15 years ago

Actually, it's got nothing to do with a group. I get the same thing if I add a layer. the only time I can save my map is when I have nothing in it.

comment:2 by ksgeograf, 15 years ago

Status: newassigned

Try to enter some text for the legend label, and then (optionally) remove the text again. I think thats the problem.

comment:3 by andrewd, 15 years ago

That doesn't work for me. I still get the same error. The only way I can save a map seems to be if I open an existing one (which is, obviously, made from another program - like Studio).

comment:4 by ksgeograf, 15 years ago

Resolution: fixed
Status: assignedclosed

I see. There is another problem, and it is group related. Every layer must have been in a group, otherwise it won't save. Its a bit tricky to fix without editing the xml.

You can create a dummy group. Then put each layer/group into the dummy group, and back into its place. Once you have done so with all layers/groups, remove the dummy group. I have comitted the fix, so it will be in the next version.

If it still does not work, please reopen the ticket.

comment:5 by jbirch, 15 years ago

Version: 2.0.1
Note: See TracTickets for help on using tickets.