Opened 9 years ago

Closed 9 years ago

#557 closed defect (fixed)

Apache crashes win32:status code 3, linux: exit signal Aborted (6)

Reported by: zspitzer Owned by:
Priority: high Milestone:
Component: Server Version: 2.0.1
Severity: blocker Keywords:
Cc: chrisclaydon External ID: 1085043

Description

This morning my 2.0.1 apache server ( from the first 2713 drop ) crashed

the apache error log contained this

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.
[Thu May 15 09:52:19 2008] [crit] Parent: child process exited with
status 3 -- Aborting.

I have no idea what caused it, the last entries in the logs before the server stopped were

<2008-05-15T09:52:17>
       SelectFeaturesSpatial.1.0.0:3(Library://CDM/TRANSPORT/SDF/aug
06-ROADS.FeatureSource,KingOra:CDM~TRANSPORT~GEOMETRY,MgFeatureAggregateOptions)
Success

apache access.log

[15/May/2008:09:49:03 +1000] "GET
/mapguide/mapagent/mapagent.fcgi?session=b4a1f50c-ffff-ffff-8000-00188b8b4aed_en_7F0000010AFC0AFB0AFA&mapname=MapDefinition1482b7a6f7a04c&clientagent=Fusion%20Viewer&operation=GETMAPIMAGE&format=PNG&version=1.0.0&locale=en&setdisplaydpi=96&setdisplayheight=371&setdisplaywidth=198&setviewcenterx=133.282275&setviewcentery=-26.260409999999993&setviewscale=86486754.1695871&clip=1&ts=1210808943897

Change History (13)

comment:1 Changed 9 years ago by zspitzer

Severity: majorblocker

Using the basic layout with the sheboygan sample with mapguide 2.0.1, using firefox 3 rc 1, this will crash the apache service (XP)

This application has requested the Runtime to terminate it in an unusual way. Please contact the application's support team for more information. [Sat May 17 14:12:03 2008] [crit] Parent: child process exited with status 3 -- Aborting.

comment:2 Changed 9 years ago by zspitzer

Priority: mediumhigh
Summary: Apache crash win32 (status code 3)Apache crashes win32:status code 3, linux: exit signal Aborted (6)

on linux i am seeing these errors, ajax viewer with FF 3.0 RC1

terminate called after throwing an instance of 'MgStreamIoException*'
terminate called after throwing an instance of 'MgStreamIoException*'
terminate called after throwing an instance of 'MgStreamIoException*'
terminate called after throwing an instance of 'MgStreamIoException*'
[Sun May 18 14:34:31 2008] [notice] child pid 20641 exit signal Aborted (6)
[Sun May 18 14:34:31 2008] [notice] child pid 20642 exit signal Aborted (6)
[Sun May 18 14:34:31 2008] [notice] child pid 20645 exit signal Aborted (6)
[Sun May 18 14:34:31 2008] [notice] child pid 20646 exit signal Aborted (6)

comment:3 Changed 9 years ago by zspitzer

I do have XP SP 3 installed as well

comment:4 Changed 9 years ago by tomfukushima

Version: 2.0.02.0.1

This works for me running Apache on both Win 2003 and XP SP2. Perhaps this is an issue specific to SP3. I'll upgrade my XP image to SP3 in a while, but won't be able to test before that.

comment:5 Changed 9 years ago by zspitzer

I just noticed that the bundled apache is 2.2.4, 2.2.8 was released on 2008-01-19

I will install the new version and see the problem is resolved

comment:6 Changed 9 years ago by zspitzer

Problem still exists with Apache 2.2.8, FF3 crashes the server, IE works fine

comment:7 Changed 9 years ago by tomfukushima

Ignore my previous comment about this working on XP SP2. It doesn't work on that either.

comment:8 Changed 9 years ago by tomfukushima

Oh, and it probably crashes on 2003 as well---just haven't tested it yet.

comment:9 Changed 9 years ago by zspitzer

confirmed occurs on 2003 as well

comment:10 Changed 9 years ago by tomfukushima

Cc: chrisclaydon added

comment:11 Changed 9 years ago by tomfukushima

Would you be able to use Fiddler to see what the difference in requests is between FF2 and FF3? Thanks, Tom

comment:12 Changed 9 years ago by tomfukushima

External ID: 1085043

comment:13 Changed 9 years ago by zspitzer

Resolution: fixed
Status: newclosed

this problem was resolved by #378

Note: See TracTickets for help on using tickets.