Opened 13 years ago

Closed 12 years ago

#547 closed defect (fixed)

Server is reporting product version not package version

Reported by: zspitzer Owned by:
Priority: high Milestone:
Component: Server Version: 2.0.0
Severity: blocker Keywords:
Cc: External ID:

Description

using a trunk build (3154) on RH ES 4, Studio 2009 can't log in

I get the following error

"Unable to complete request from site" there is an error in xml document (23,4)

using fiddler the xml looks ok, but i did notice the version being reported as 7.0.0.1 could that be the problem?

I think it's reporting the product version as opposed to the mapguide version, ie trunk/MgDev/Common/ProductVersion.h

2.0 released binary on windows reports

<SiteServer?>

<DisplayName?></DisplayName?> <Status>Online</Status> <Version>2.0.0.2308</Version>

whereas trunk build returns

<SiteServer?>

<DisplayName?></DisplayName?> <Status>Online</Status> <Version>7.0.0.1</Version>

Attachments (1)

productversion.patch (372 bytes) - added by zspitzer 13 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 13 years ago by tomfukushima

Not sure why we have 7.0.0.1 in there. I guess that was the next logical progression after MapGuide 6.5, even though the two are completely unrelated. The 7.0.0.1 should really just be the current trunk version, which now would be 2.1.0.0. Could you change all the 7.0.0.1's and 7,0,0,1's in the code to the equivalent 2.1, recompile and test that it works, and then submit a patch for that? Thanks, Tom.

comment:2 Changed 13 years ago by zspitzer

I changed the product version which worked but i am still getting the same error from studio

AvailablePhysicalMemory? looks rather too negative, and the memory values are 0

<?xml version="1.0" encoding="UTF-8"?>
<SiteInformation xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="SiteInformation-1.0.0.xsd">
	<SiteServer>
		<DisplayName></DisplayName>
		<Status>Online</Status>
		<Version>2.0.0.1</Version>
		<OperatingSystem>
			<AvailablePhysicalMemory>-9223372036854775808</AvailablePhysicalMemory>
			<TotalPhysicalMemory>0</TotalPhysicalMemory>
			<AvailableVirtualMemory>0</AvailableVirtualMemory>
			<TotalVirtualMemory>0</TotalVirtualMemory>
			<Version>Linux, Kernel Version: 2.6.9-67.0.7.ELxenU</Version>
		</OperatingSystem>
	</SiteServer>
	<Statistics>
		<AdminOperationsQueueCount>0</AdminOperationsQueueCount>
		<ClientOperationsQueueCount>0</ClientOperationsQueueCount>
		<SiteOperationsQueueCount>0</SiteOperationsQueueCount>
		<AverageOperationTime>240</AverageOperationTime>
		<CpuUtilization>37</CpuUtilization>
		<TotalOperationTime>6</TotalOperationTime>
		<TotalActiveConnections>10</TotalActiveConnections>
		<TotalConnections>10</TotalConnections>
		<TotalOperationsProcessed>25</TotalOperationsProcessed>
		<TotalOperationsReceived>26</TotalOperationsReceived>
		<Uptime>104</Uptime>
	</Statistics>
</SiteInformation>

Changed 13 years ago by zspitzer

Attachment: productversion.patch added

comment:3 Changed 13 years ago by tomfukushima

Is this machine available on the Internet? If so could you email me (tom.fukushima at autodesk.com) the details directly? I could then start the debugger up in Studio and see why it is failing.

comment:4 Changed 12 years ago by zspitzer

over in #633 it looks like the problem might be that <DisplayName/?> is being returned rather than <DisplayName?></DisplayName?> which is tripping up studio

comment:5 Changed 12 years ago by tomfukushima

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.