Opened 12 years ago

Closed 10 years ago

#347 closed defect (wontfix)

Building cgiagent fails because of "missing" liblib_json.so

Reported by: jbirch Owned by:
Priority: medium Milestone:
Component: Build System Version: 2.0.0
Severity: major Keywords:
Cc: External ID:

Description

I'm trying to build MapGuide (r2519) on Ubuntu 7.10.

Everything goes according to plan until I get to the final make. At this point I get an error about a missing liblib_json.so, even though it exists at:

administrator@vm-mapguide-ubuntu:~/mgsvn$ find . -name "*lib_json.so*"
./Oem/jsoncpp/buildscons/linux-gcc/src/lib_json/liblib_json.so
./Oem/jsoncpp/lib/liblib_json.so

Is it possible that there's a reference to the jsoncpp lib missing? Here's the error message that I get:

Making all in CgiAgent
make[3]: Entering directory `/home/administrator/mgsvn/Web/src/CgiAgent'
if g++ -DPACKAGE_NAME=\"mapguide\" -DPACKAGE_TARNAME=\"mapguide\" -DPACKAGE_VERSION=\"2.0.0\" -DPACKAGE_STRING=\"mapguide\ 2.0.0\" -DPACKAGE_BUGREPORT=\"http://mapguide.osgeo.org\" -DPACKAGE=\"mapguide\" -DVERSION=\"2.0.0\" -DPACKAGE=\"mapguide\" -DVERSION=\"2.0.0\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DSTDC_HEADERS=1 -DHAVE_UNISTD_H=1 -DHAVE_MATH_H=1 -DHAVE_NETDB_H=1 -DHAVE_NETINET_IN_H=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_SOCKET_H=1 -DHAVE_GETHOSTBYNAME=1 -DHAVE_SOCKET=1 -DHAVE_HTONS=1 -DHAVE_CONNECT=1 -DHAVE_SHUTDOWN=1 -I. -I. -I../../../Common/Foundation -I../../../Common/Geometry -I../../../Common/PlatformBase -I../../../Common/MapGuideCommon -I../../../Common/MdfModel -I../../../Oem/ACE/ACE_wrappers -I../HttpHandler -I../WebSupport -I../MapAgentCommon    -O2 -g -pipe -march=i386 -mcpu=i686 -fno-use-cxa-atexit -fexceptions -MT MapAgentGetParser.o -MD -MP -MF ".deps/MapAgentGetParser.Tpo" -c -o MapAgentGetParser.o `test -f '../MapAgentCommon/MapAgentGetParser.cpp' || echo './'`../MapAgentCommon/MapAgentGetParser.cpp; \
        then mv -f ".deps/MapAgentGetParser.Tpo" ".deps/MapAgentGetParser.Po"; else rm -f ".deps/MapAgentGetParser.Tpo"; exit 1; fi
`-mcpu=' is deprecated. Use `-mtune=' or '-march=' instead.
if g++ -DPACKAGE_NAME=\"mapguide\" -DPACKAGE_TARNAME=\"mapguide\" -DPACKAGE_VERSION=\"2.0.0\" -DPACKAGE_STRING=\"mapguide\ 2.0.0\" -DPACKAGE_BUGREPORT=\"http://mapguide.osgeo.org\" -DPACKAGE=\"mapguide\" -DVERSION=\"2.0.0\" -DPACKAGE=\"mapguide\" -DVERSION=\"2.0.0\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DSTDC_HEADERS=1 -DHAVE_UNISTD_H=1 -DHAVE_MATH_H=1 -DHAVE_NETDB_H=1 -DHAVE_NETINET_IN_H=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_SOCKET_H=1 -DHAVE_GETHOSTBYNAME=1 -DHAVE_SOCKET=1 -DHAVE_HTONS=1 -DHAVE_CONNECT=1 -DHAVE_SHUTDOWN=1 -I. -I. -I../../../Common/Foundation -I../../../Common/Geometry -I../../../Common/PlatformBase -I../../../Common/MapGuideCommon -I../../../Common/MdfModel -I../../../Oem/ACE/ACE_wrappers -I../HttpHandler -I../WebSupport -I../MapAgentCommon    -O2 -g -pipe -march=i386 -mcpu=i686 -fno-use-cxa-atexit -fexceptions -MT CgiPostParser.o -MD -MP -MF ".deps/CgiPostParser.Tpo" -c -o CgiPostParser.o CgiPostParser.cpp; \
        then mv -f ".deps/CgiPostParser.Tpo" ".deps/CgiPostParser.Po"; else rm -f ".deps/CgiPostParser.Tpo"; exit 1; fi
`-mcpu=' is deprecated. Use `-mtune=' or '-march=' instead.
if g++ -DPACKAGE_NAME=\"mapguide\" -DPACKAGE_TARNAME=\"mapguide\" -DPACKAGE_VERSION=\"2.0.0\" -DPACKAGE_STRING=\"mapguide\ 2.0.0\" -DPACKAGE_BUGREPORT=\"http://mapguide.osgeo.org\" -DPACKAGE=\"mapguide\" -DVERSION=\"2.0.0\" -DPACKAGE=\"mapguide\" -DVERSION=\"2.0.0\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DSTDC_HEADERS=1 -DHAVE_UNISTD_H=1 -DHAVE_MATH_H=1 -DHAVE_NETDB_H=1 -DHAVE_NETINET_IN_H=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_SOCKET_H=1 -DHAVE_GETHOSTBYNAME=1 -DHAVE_SOCKET=1 -DHAVE_HTONS=1 -DHAVE_CONNECT=1 -DHAVE_SHUTDOWN=1 -I. -I. -I../../../Common/Foundation -I../../../Common/Geometry -I../../../Common/PlatformBase -I../../../Common/MapGuideCommon -I../../../Common/MdfModel -I../../../Oem/ACE/ACE_wrappers -I../HttpHandler -I../WebSupport -I../MapAgentCommon    -O2 -g -pipe -march=i386 -mcpu=i686 -fno-use-cxa-atexit -fexceptions -MT CgiResponseHandler.o -MD -MP -MF ".deps/CgiResponseHandler.Tpo" -c -o CgiResponseHandler.o CgiResponseHandler.cpp; \
        then mv -f ".deps/CgiResponseHandler.Tpo" ".deps/CgiResponseHandler.Po"; else rm -f ".deps/CgiResponseHandler.Tpo"; exit 1; fi
`-mcpu=' is deprecated. Use `-mtune=' or '-march=' instead.
if g++ -DPACKAGE_NAME=\"mapguide\" -DPACKAGE_TARNAME=\"mapguide\" -DPACKAGE_VERSION=\"2.0.0\" -DPACKAGE_STRING=\"mapguide\ 2.0.0\" -DPACKAGE_BUGREPORT=\"http://mapguide.osgeo.org\" -DPACKAGE=\"mapguide\" -DVERSION=\"2.0.0\" -DPACKAGE=\"mapguide\" -DVERSION=\"2.0.0\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DSTDC_HEADERS=1 -DHAVE_UNISTD_H=1 -DHAVE_MATH_H=1 -DHAVE_NETDB_H=1 -DHAVE_NETINET_IN_H=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_SOCKET_H=1 -DHAVE_GETHOSTBYNAME=1 -DHAVE_SOCKET=1 -DHAVE_HTONS=1 -DHAVE_CONNECT=1 -DHAVE_SHUTDOWN=1 -I. -I. -I../../../Common/Foundation -I../../../Common/Geometry -I../../../Common/PlatformBase -I../../../Common/MapGuideCommon -I../../../Common/MdfModel -I../../../Oem/ACE/ACE_wrappers -I../HttpHandler -I../WebSupport -I../MapAgentCommon    -O2 -g -pipe -march=i386 -mcpu=i686 -fno-use-cxa-atexit -fexceptions -MT MapAgentStrings.o -MD -MP -MF ".deps/MapAgentStrings.Tpo" -c -o MapAgentStrings.o `test -f '../MapAgentCommon/MapAgentStrings.cpp' || echo './'`../MapAgentCommon/MapAgentStrings.cpp; \
        then mv -f ".deps/MapAgentStrings.Tpo" ".deps/MapAgentStrings.Po"; else rm -f ".deps/MapAgentStrings.Tpo"; exit 1; fi
`-mcpu=' is deprecated. Use `-mtune=' or '-march=' instead.
if g++ -DPACKAGE_NAME=\"mapguide\" -DPACKAGE_TARNAME=\"mapguide\" -DPACKAGE_VERSION=\"2.0.0\" -DPACKAGE_STRING=\"mapguide\ 2.0.0\" -DPACKAGE_BUGREPORT=\"http://mapguide.osgeo.org\" -DPACKAGE=\"mapguide\" -DVERSION=\"2.0.0\" -DPACKAGE=\"mapguide\" -DVERSION=\"2.0.0\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DSTDC_HEADERS=1 -DHAVE_UNISTD_H=1 -DHAVE_MATH_H=1 -DHAVE_NETDB_H=1 -DHAVE_NETINET_IN_H=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_SOCKET_H=1 -DHAVE_GETHOSTBYNAME=1 -DHAVE_SOCKET=1 -DHAVE_HTONS=1 -DHAVE_CONNECT=1 -DHAVE_SHUTDOWN=1 -I. -I. -I../../../Common/Foundation -I../../../Common/Geometry -I../../../Common/PlatformBase -I../../../Common/MapGuideCommon -I../../../Common/MdfModel -I../../../Oem/ACE/ACE_wrappers -I../HttpHandler -I../WebSupport -I../MapAgentCommon    -O2 -g -pipe -march=i386 -mcpu=i686 -fno-use-cxa-atexit -fexceptions -MT EchoTest.o -MD -MP -MF ".deps/EchoTest.Tpo" -c -o EchoTest.o EchoTest.cpp; \
        then mv -f ".deps/EchoTest.Tpo" ".deps/EchoTest.Po"; else rm -f ".deps/EchoTest.Tpo"; exit 1; fi
`-mcpu=' is deprecated. Use `-mtune=' or '-march=' instead.
if g++ -DPACKAGE_NAME=\"mapguide\" -DPACKAGE_TARNAME=\"mapguide\" -DPACKAGE_VERSION=\"2.0.0\" -DPACKAGE_STRING=\"mapguide\ 2.0.0\" -DPACKAGE_BUGREPORT=\"http://mapguide.osgeo.org\" -DPACKAGE=\"mapguide\" -DVERSION=\"2.0.0\" -DPACKAGE=\"mapguide\" -DVERSION=\"2.0.0\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DSTDC_HEADERS=1 -DHAVE_UNISTD_H=1 -DHAVE_MATH_H=1 -DHAVE_NETDB_H=1 -DHAVE_NETINET_IN_H=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_SOCKET_H=1 -DHAVE_GETHOSTBYNAME=1 -DHAVE_SOCKET=1 -DHAVE_HTONS=1 -DHAVE_CONNECT=1 -DHAVE_SHUTDOWN=1 -I. -I. -I../../../Common/Foundation -I../../../Common/Geometry -I../../../Common/PlatformBase -I../../../Common/MapGuideCommon -I../../../Common/MdfModel -I../../../Oem/ACE/ACE_wrappers -I../HttpHandler -I../WebSupport -I../MapAgentCommon    -O2 -g -pipe -march=i386 -mcpu=i686 -fno-use-cxa-atexit -fexceptions -MT CgiAgent.o -MD -MP -MF ".deps/CgiAgent.Tpo" -c -o CgiAgent.o CgiAgent.cpp; \
        then mv -f ".deps/CgiAgent.Tpo" ".deps/CgiAgent.Po"; else rm -f ".deps/CgiAgent.Tpo"; exit 1; fi
`-mcpu=' is deprecated. Use `-mtune=' or '-march=' instead.
if g++ -DPACKAGE_NAME=\"mapguide\" -DPACKAGE_TARNAME=\"mapguide\" -DPACKAGE_VERSION=\"2.0.0\" -DPACKAGE_STRING=\"mapguide\ 2.0.0\" -DPACKAGE_BUGREPORT=\"http://mapguide.osgeo.org\" -DPACKAGE=\"mapguide\" -DVERSION=\"2.0.0\" -DPACKAGE=\"mapguide\" -DVERSION=\"2.0.0\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DSTDC_HEADERS=1 -DHAVE_UNISTD_H=1 -DHAVE_MATH_H=1 -DHAVE_NETDB_H=1 -DHAVE_NETINET_IN_H=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_SOCKET_H=1 -DHAVE_GETHOSTBYNAME=1 -DHAVE_SOCKET=1 -DHAVE_HTONS=1 -DHAVE_CONNECT=1 -DHAVE_SHUTDOWN=1 -I. -I. -I../../../Common/Foundation -I../../../Common/Geometry -I../../../Common/PlatformBase -I../../../Common/MapGuideCommon -I../../../Common/MdfModel -I../../../Oem/ACE/ACE_wrappers -I../HttpHandler -I../WebSupport -I../MapAgentCommon    -O2 -g -pipe -march=i386 -mcpu=i686 -fno-use-cxa-atexit -fexceptions -MT InitializeWebTier.o -MD -MP -MF ".deps/InitializeWebTier.Tpo" -c -o InitializeWebTier.o `test -f '../WebSupport/InitializeWebTier.cpp' || echo './'`../WebSupport/InitializeWebTier.cpp; \
        then mv -f ".deps/InitializeWebTier.Tpo" ".deps/InitializeWebTier.Po"; else rm -f ".deps/InitializeWebTier.Tpo"; exit 1; fi
`-mcpu=' is deprecated. Use `-mtune=' or '-march=' instead.
/bin/sh ../../../libtool --tag=CXX --mode=link g++  -O2 -g -pipe -march=i386 -mcpu=i686 -fno-use-cxa-atexit -fexceptions   -o mapagent -version-info 7:0:0 -L../../../Oem/ACE/ACE_wrappers/ace -L../../../Oem/dbxml-2.3.10/install/lib -L../../../Common/CoordinateSystem -L../../../Common/MdfModel -L../../../Common/MdfParser -L../../../Common/Foundation -L../../../Common/Geometry -L../../../Common/PlatformBase -L../../../Common/MapGuideCommon -L../HttpHandler MapAgentGetParser.o CgiPostParser.o CgiResponseHandler.o MapAgentStrings.o EchoTest.o CgiAgent.o InitializeWebTier.o -lACE -lxerces-c -lMgFoundation -lMgGeometry -lMgPlatformBase -lMgMdfModel -lMgMdfParser -lMgHttpHandler
mkdir .libs
libtool: link: warning: `-version-info' is ignored for programs
g++ -O2 -g -pipe -march=i386 -mcpu=i686 -fno-use-cxa-atexit -fexceptions -o .libs/mapagent MapAgentGetParser.o CgiPostParser.o CgiResponseHandler.o MapAgentStrings.o EchoTest.o CgiAgent.o InitializeWebTier.o  -L/home/administrator/mgsvn/Oem/ACE/ACE_wrappers/ace -L/home/administrator/mgsvn/Oem/dbxml-2.3.10/install/lib -L/home/administrator/mgsvn/Common/CoordinateSystem -L/home/administrator/mgsvn/Common/MdfModel -L/home/administrator/mgsvn/Common/MdfParser -L/home/administrator/mgsvn/Common/Foundation -L/home/administrator/mgsvn/Common/Geometry -L/home/administrator/mgsvn/Common/PlatformBase -L/home/administrator/mgsvn/Common/MapGuideCommon -L/home/administrator/mgsvn/Web/src/HttpHandler -lACE -lxerces-c /home/administrator/mgsvn/Common/Foundation/.libs/libMgFoundation.so /home/administrator/mgsvn/Common/Geometry/.libs/libMgGeometry.so /home/administrator/mgsvn/Common/PlatformBase/.libs/libMgPlatformBase.so /home/administrator/mgsvn/Common/MdfModel/.libs/libMgMdfModel.so /home/administrator/mgsvn/Common/MdfParser/.libs/libMgMdfParser.so /home/administrator/mgsvn/Web/src/HttpHandler/.libs/libMgHttpHandler.so  -Wl,--rpath -Wl,/usr/local/mapguideopensource/lib -Wl,--rpath -Wl,/usr/local/mapguideopensource/webserverextensions/lib
/usr/bin/ld: warning: liblib_json.so, needed by /home/administrator/mgsvn/Web/src/HttpHandler/.libs/libMgHttpHandler.so, not found (try using -rpath or -rpath-link)
/home/administrator/mgsvn/Web/src/HttpHandler/.libs/libMgHttpHandler.so: undefined reference to `Json::Value::Value(bool)'
/home/administrator/mgsvn/Web/src/HttpHandler/.libs/libMgHttpHandler.so: undefined reference to `Json::Value::Value(Json::StaticString const&)'
/home/administrator/mgsvn/Web/src/HttpHandler/.libs/libMgHttpHandler.so: undefined reference to `Json::Value::resize(int)'
/home/administrator/mgsvn/Web/src/HttpHandler/.libs/libMgHttpHandler.so: undefined reference to `Json::Value::operator[](Json::StaticString const&)'
/home/administrator/mgsvn/Web/src/HttpHandler/.libs/libMgHttpHandler.so: undefined reference to `Json::Value::~Value()'
/home/administrator/mgsvn/Web/src/HttpHandler/.libs/libMgHttpHandler.so: undefined reference to `Json::Value::operator[](int)'
/home/administrator/mgsvn/Web/src/HttpHandler/.libs/libMgHttpHandler.so: undefined reference to `Json::Value::Value(std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)'
/home/administrator/mgsvn/Web/src/HttpHandler/.libs/libMgHttpHandler.so: undefined reference to `Json::FastWriter::write(Json::Value const&)'
/home/administrator/mgsvn/Web/src/HttpHandler/.libs/libMgHttpHandler.so: undefined reference to `Json::Value::Value(Json::Value const&)'
/home/administrator/mgsvn/Web/src/HttpHandler/.libs/libMgHttpHandler.so: undefined reference to `Json::Value::operator=(Json::Value const&)'
/home/administrator/mgsvn/Web/src/HttpHandler/.libs/libMgHttpHandler.so: undefined reference to `Json::Value::append(Json::Value const&)'
/home/administrator/mgsvn/Web/src/HttpHandler/.libs/libMgHttpHandler.so: undefined reference to `Json::Value::Value(Json::ValueType)'
/home/administrator/mgsvn/Web/src/HttpHandler/.libs/libMgHttpHandler.so: undefined reference to `Json::Writer::~Writer()'
/home/administrator/mgsvn/Web/src/HttpHandler/.libs/libMgHttpHandler.so: undefined reference to `Json::FastWriter::FastWriter()'
/home/administrator/mgsvn/Web/src/HttpHandler/.libs/libMgHttpHandler.so: undefined reference to `Json::Value::operator[](std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)'
/home/administrator/mgsvn/Web/src/HttpHandler/.libs/libMgHttpHandler.so: undefined reference to `vtable for Json::FastWriter'
collect2: ld returned 1 exit status
make[3]: *** [mapagent] Error 1
make[3]: Leaving directory `/home/administrator/mgsvn/Web/src/CgiAgent'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/administrator/mgsvn/Web/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/administrator/mgsvn/Web'
make: *** [all-recursive] Error 1

Attachments (1)

CgiAgent_Makefile.am.patch (713 bytes) - added by jbirch 12 years ago.
Patch to CgiAgent? Makefile.am which resolves this issue

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by jbirch

Attachment: CgiAgent_Makefile.am.patch added

Patch to CgiAgent? Makefile.am which resolves this issue

comment:1 Changed 12 years ago by jbirch

For information, this is my configuration when building on Ubuntu 7.10:

administrator@vm-mapguide-ubuntu:~$ automake --version
automake (GNU automake) 1.9.6

administrator@vm-mapguide-ubuntu:~$ autoconf --version
autoconf (GNU Autoconf) 2.61

administrator@vm-mapguide-ubuntu:~$ libtoolize --version
libtoolize (GNU libtool) 1.5.24

administrator@vm-mapguide-ubuntu:~$ make --version
GNU Make 3.81

comment:2 Changed 11 years ago by sdoyle

Building for Ubuntu 8.04, I can confirm that this patch works.

comment:3 Changed 10 years ago by jbirch

Resolution: wontfix
Status: newclosed

Closing due to lack of interest by devs.

Note: See TracTickets for help on using tickets.