Opened 6 years ago

Closed 5 years ago

#2579 closed defect (fixed)

Symbols are rotated with plot to HP printer landscape

Reported by: zhanga Owned by:
Priority: medium Milestone:
Component: General Version: 3.0.0
Severity: trivial Keywords:
Cc: External ID:

Description

This defect happens on Autodesk Map 3D. But it is an issue of Stylize Engine. The detail step is:

  1. Open Autodesk Map 3D
  2. Go into paper space and select a Landscape paper size
  3. Plot to an HP plotter

Expected result: Drawing will plot the drawing as defined. Actual result: The symbols in the legend are rotated 90 degrees

Attachments (1)

2579.patch (611 bytes) - added by zhanga 6 years ago.
Patch for ticket #2579

Download all attachments as: .zip

Change History (3)

comment:1 Changed 6 years ago by zhanga

This issue only happens on point symbol. The reason is that Map 3D uses method tylizationUtil::RenderCompositeSymbolization?() to create the symbol in legend. I checked the implementation and found that this method doesn't account for the viewport rotation. The issue is fixed by add the viewport rotation.

Changed 6 years ago by zhanga

Attachment: 2579.patch added

Patch for ticket #2579

comment:2 Changed 5 years ago by jng

Resolution: fixed
Status: newclosed

Fixed r8864

Note: See TracTickets for help on using tickets.