Opened 9 years ago

Closed 9 years ago

#1915 closed defect (fixed)

Labels failed to display for flexible web layout

Reported by: liuar Owned by: liuar
Priority: low Milestone:
Component: General Version: 2.1.0
Severity: trivial Keywords:
Cc: External ID:

Description

  1. Restart web extension to clear the cache.
  2. Open a basic web layout
  3. Open a flexible web layout and open a widget like Theme or FeatureInfo?

Result: Labels on taskpane are not displayed.

Change History (2)

comment:1 Changed 9 years ago by liuar

This is caused by the cache in PhpLocalizer?.cpp in php api. It uses a map to cache localized texts and uses the local as the key. However, the local for flexible web layout and basic web layout are both "en". That means if user loads basic web layout before the flexible weblayout, then the localized string for flexible web layout will never be cached and displyed, vice versa.

To resolve the problem, I changes the key of the caching structure from local to LocalizationPath?+Local, and both localized strings for basic web layout and flexible web layout will be cached.

comment:2 Changed 9 years ago by liuar

Resolution: fixed
Status: newclosed

Fixed in [6429].

Note: See TracTickets for help on using tickets.