Opened 10 years ago

Closed 10 years ago

#997 closed defect (fixed)

g.proj returns wrong datumtrans

Reported by: martinl Owned by: grass-dev@…
Priority: blocker Milestone: 6.4.0
Component: Projections/Datums Version: svn-releasebranch64
Keywords: g.proj, datums Cc:
CPU: Unspecified Platform: Unspecified

Description

g.proj behaves strangely when printing datum transform paramaters. E.g.

g.proj epsg=3004 datumtrans=-1

nothing is printed out even epgs code is given.

Setting datumtrans also doesn't work, e.g.

g.proj epsg=3004 datumtrans=1 -j
...
+towgs84=-104.1,-49.1,-9.9,0.971,-2.917,0.714,-11.68
...

same with

g.proj epsg=3004 datumtrans=2 -j
...
+towgs84=-104.1,-49.1,-9.9,0.971,-2.917,0.714,-11.68
...

Everything is working with -t flag, e.g.

g.proj epsg=3004 datumtrans=-1 -t
---
1
Used in whole rome40 region
towgs84=-225.000,-65.000,9.000
Default 3-Parameter Transformation (May not be optimum for older datums; use this only if no more appropriate options are available.)
---
2
Used in Italy (Peninsular Part)
towgs84=-104.1,-49.1,-9.9,0.971,-2.917,0.714,-11.68
Accuracy 3-4m
---
3
Used in Italy (Sardinia)
towgs84=-168.6,-34.0,38.6,-0.374,-0.679,-1.379,-9.48
Accuracy 3-4m
---
4
Used in Italy (Sicily)
towgs84=-50.2,-50.4,84.8,-0.690,-2.012,0.459,-28.08
Accuracy 3-4m

Change History (2)

comment:1 Changed 10 years ago by martinl

In RC5 everything works well, i.e. without -t. What is purpose of this flag? Thanks, Martin

comment:2 Changed 10 years ago by hamish

Keywords: datums added
Resolution: fixed
Status: newclosed

fixed in svn.

see http://thread.gmane.org/gmane.comp.gis.grass.devel/38870 and http://fwarmerdam.blogspot.com/2010/03/in-last-few-weeks-i-believe-i-have-made.html

thanks to Paul for fixing it and Markus for pointing out the cause.

to be continued in grass7 once the dust settles at the gdal end....

Hamish

Note: See TracTickets for help on using tickets.