Opened 10 years ago

Closed 9 years ago

#976 closed defect (fixed)

WxGUI histogram tool-bar icons messed up in WinGRASS

Reported by: marisn Owned by: grass-dev@…
Priority: minor Milestone: 6.4.0
Component: wxGUI Version: svn-releasebranch64
Keywords: histogram, wingrass Cc:
CPU: x86-32 Platform: MSWindows Vista

Description

When I open wxgui histogram window, it's tool-bar icons are small and overlapping and partially hidden behind histogram canvas.

WinGRASS-6.4.SVN-r41233-1 on Windows Vista

Attachments (1)

wxgui_histogram_icon_issue.png (24.8 KB) - added by marisn 10 years ago.
Those icons don't look right

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by marisn

Those icons don't look right

comment:1 Changed 10 years ago by hamish

Keywords: histogram wingrass added; wxgui windows removed

I can reproduce this in Windows XP but not on Linux.

svn props seem to be correct in gui/icons/silk/ and icons/grass2/.

Hamish

comment:2 in reply to:  1 ; Changed 9 years ago by hellik

Replying to hamish:

I can reproduce this in Windows XP but not on Linux.

svn props seem to be correct in gui/icons/silk/ and icons/grass2/.

Hamish

still valid?

tried in WinGRASS-6.4.SVN-r42833-1-Setup.exe on WinVista32, no overlapping and messed icons.

Helmut

comment:3 in reply to:  2 Changed 9 years ago by hamish

Resolution: fixed
Status: newclosed

Replying to hellik:

tried in WinGRASS-6.4.SVN-r42833-1-Setup.exe on WinVista32, no overlapping and messed icons.

same here with the 6.4 r42845 nightly build on XP. looks ok now.


With no raster maps loaded into the layer list, if I press the left-most icon on the histogram gui toolbar I got an error in the main gui output tab when I tried a bit earlier, but not now. (something about flush?) shrug.

Hamish

Note: See TracTickets for help on using tickets.