Opened 10 years ago

Closed 7 years ago

#962 closed defect (fixed)

wxGUI crash when moving an undocked map display toolbox

Reported by: msieczka Owned by: grass-dev@…
Priority: critical Milestone: 6.4.0
Component: wxGUI Version: svn-releasebranch64
Keywords: toolbar Cc:
CPU: x86-64 Platform: All

Description

  1. select a map display window
  1. undock it's toolbox
  1. move it around - crash:
GRASS 6.4.0svn (nowa_lokacja):~ > 
(python:26751): Pango-CRITICAL **: pango_layout_get_cursor_pos: assertion `index >= 0 && index <= layout->length' failed

6.4 branch r37101, Debian stable amd64, python 2.5.2, wx 2.8.7.

Change History (7)

comment:1 Changed 10 years ago by martinl

Unable to reproduce it. Undocking works.

6.4 branch, r41467, Debian unstable 32bit, python 2.5.5, wx 2.8.10.1 (gtk2-unicode)

Please try to upgrade your wx libs.

comment:2 Changed 10 years ago by marisn

Docking an undocking works just fine when there are NO maps displayed.

Steps to reproduce:

  • add raster or vector map;
  • undock map display toolbar;
  • dock back map display toolbar --> KaBOOM!
Problem signature:
  Problem Event Name:	APPCRASH
  Application Name:	python.exe
  Application Version:	0.0.0.0
  Application Timestamp:	47bd6a89
  Fault Module Name:	wxmsw28u_core_vc.dll
  Fault Module Version:	2.8.9.1
  Fault Module Timestamp:	4983882d
  Exception Code:	c0000005
  Exception Offset:	00006ef0
  OS Version:	6.0.6002.2.2.0.256.6
  Locale ID:	1062
  Additional Information 1:	810f
  Additional Information 2:	3f6c89115c5b2ca50b73ad2f37d5d605
  Additional Information 3:	2fd0
  Additional Information 4:	de35a5710e4652ba50fa82643c57e6a1
GRASS 6.4.0svn (spearfish60)> g.gui wxpython

WARNING: Vector digitizer is not available (No module named grass6_wxvdigit).

Note that the vector digitizer is currently not working under MS Windows (hopefu
lly this will be fixed soon). Please keep an eye out for updated versions of GRA
SS.
BR╬DIN┬JUMS:Unable to execute command

WinGRASS-6.4.SVN-r41749-1 running Windows Vista.

comment:3 Changed 9 years ago by neteler

Platform: LinuxMSWindows Vista

comment:4 Changed 9 years ago by hamish

Keywords: toolbar added
Platform: MSWindows VistaAll

just another data point:

I can reproduce this in 6.4 and 6.5, but I have to try for a minute or two first (it's on a rather fast machine, which may help, although I am running X tunneled over ssh from it). I got no error message when the wxGUI was launched automatically at startup.

I notice that draging the toolbar is not the most responsive thing once a map is loaded. I had to try harder in 6.5, but that might just be chance.

Running same Debian/stable (lenny) amd64 with python-wxgtk2.8 version 2.8.7.1-1.1+lenny1 and python 2.5.2-3.

Also I notice that if I remove or uncheck everything on the list the last map standing does not clear from the display window. If I press the erase button, the image comes back after I tear-away or reconnect the display toolbar.

I suspect that this is an upstream bug, and there is little we can do about it.. but no idea.

wow, I just restarted grass in text mode and then g.gui from the command prompt, and it died after adding a raster map and then a vector map with:

(hamish:10965): Pango-CRITICAL **: pango_break: assertion `attrs != NULL' failed
(hamish:10965): Pango-WARNING **: shaping failure, expect ugly output. shape-engine='BasicEngineFc', font='Bitstream Vera Sans 9.9990234375', text=''

maybe I should try restarting X now..

Hamish

comment:5 Changed 8 years ago by martinl

Still relevant with recent SVN version?

comment:6 in reply to:  5 Changed 8 years ago by marisn

Replying to martinl:

Still relevant with recent SVN version?

GRASS 7 r48707 still crashes.

dev-python/wxpython-2.8.12.0 x11-libs/wxGTK-2.8.12.0 x11-libs/gtk+-2.24.6 x11-libs/gtk+-3.0.12-r1 dev-python/pygtk-2.24.0-r1

comment:7 Changed 7 years ago by neteler

Resolution: fixed
Status: newclosed

No more crashes in current 6.4.svn and 7.svn.

Closing since it appears to be fixed. Reopen if needed.

Note: See TracTickets for help on using tickets.