Opened 12 years ago

Closed 12 years ago

#926 closed defect (fixed)

Error writing workspace file: 'bool object has no attribute replace'

Reported by: epatton Owned by: martinl
Priority: normal Milestone: 6.5.0
Component: wxGUI Version: svn-develbranch6
Keywords: workspace Cc: grass-dev@…
CPU: x86-64 Platform: Linux

Description

I've loaded several vector maps to the Layer Manager, and hit Ctrl-S, gave a workspace file name, and after hitting Enter a pop-up dialog reads:

Writing current settings to workspace file failed ('bool' object has no attribute 'replace').

~ Eric.

Change History (5)

comment:1 Changed 12 years ago by martinl

Cc: martinl added

Seems to work here. Tested with GRASS 6.5 from SVN.

comment:2 Changed 12 years ago by epatton

I just tried a fresh svn checkout and install of 6.5.svn this morning, and I get the same error. There were no errors during configure or make; error.log is empty. Can anyone else confirm?

~ Eric.

comment:3 Changed 12 years ago by epatton

Here's what actually gets written to the workspace file; maybe the point at which it gets truncated gives a clue:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE gxw SYSTEM "grass-gxw.dtd">
<gxw>
    <layer_manager dim="0,25,511,725">
    </layer_manager>
    <display render="1" mode="6" showCompExtent="0" constrainRes="0" dim="517,25,757,725" extent="442848.559319,7806497.907494,545333.166481,7895662.234149">
        <layer type="grid" name="grid" checked="0" opacity="1.000000">
            <task name="d.grid">
                <parameter name="verbose">

~ Eric.

comment:4 Changed 12 years ago by martinl

Cc: grass-dev@… added; martinl removed
Owner: changed from grass-dev@… to martinl
Status: newassigned

Right, hopefully fixed r41049 (6.5), r41050 (6.4), r41051 (7.0).

comment:5 Changed 12 years ago by epatton

Resolution: fixed
Status: assignedclosed

Thanks, Martin! Workspaces can be saved and opened with no errors in 6.4, 6.5 and 7.

Much appreciated,

~ Eric.

Note: See TracTickets for help on using tickets.