Opened 13 years ago

Closed 13 years ago

#921 closed defect (invalid)

Error querying vector map in wxpython Map Display window

Reported by: epatton Owned by: grass-dev@…
Priority: normal Milestone: 6.5.0
Component: wxGUI Version: svn-develbranch6
Keywords: Cc:
CPU: x86-64 Platform: Linux

Description

I get the following error after clicking on a vector in the Map Display window using the 'Query raster/vector map(s)' button:

Traceback (most recent call last):
  File "/usr/local/grass-6.5.svn/etc/wxpython/gui_modules/ma
pdisp_window.py", line 1078, in MouseActions

self.OnLeftUp(event)
  File "/usr/local/grass-6.5.svn/etc/wxpython/gui_modules/ma
pdisp_window.py", line 1881, in OnLeftUp

self.parent.QueryVector(self.mouse['begin'][0],
self.mouse['begin'][1])
  File "/usr/local/grass-6.5.svn/etc/wxpython/gui_modules/ma
pdisp.py", line 1473, in QueryVector

action="update")
  File "/usr/local/grass-6.5.svn/etc/wxpython/gui_modules/db
m_dialogs.py", line 106, in __init__

self.UpdateDialog(query=query, cats=cats)
  File "/usr/local/grass-6.5.svn/etc/wxpython/gui_modules/db
m_dialogs.py", line 415, in UpdateDialog

for idx in range(len(columns[key]['values'])):
KeyError
:
'cat'

Raster querying using the same tool works ok, though. I'm not sure if this is related to the other bug I just posted today about not being able to query my vector databases.

~ Eric.

Change History (1)

comment:1 by epatton, 13 years ago

Resolution: invalid
Status: newclosed

This error was caused by an incorrect database connection parameter; closing ticket.

~ Eric.

Note: See TracTickets for help on using tickets.