Opened 11 years ago

Closed 11 years ago

#753 closed defect (worksforme)

Map elements (scalebar, legend, etc) frozen and crash GUI

Reported by: cmbarton Owned by: grass-dev@…
Priority: major Milestone: 6.5.0
Component: Compiling Version: svn-develbranch6
Keywords: legend, barscale Cc: martinl, kyngchaos
CPU: OSX/Intel Platform: MacOSX

Description

In the current version of the wxpython GUI in GRASS 6.5 compiled today, all map elements (formerly overlays) are frozen once they are displayed. Attempting to move one with a mouse will crash the GUI.

Change History (5)

comment:1 Changed 11 years ago by cmbarton

Looking at the Mac crash reporter, it lists the last items before the crash as...

0 _core_.so 0x00567536 wxMemoryBufferData::ResizeIfNeeded?(unsigned long) + 18 1 libwx_macud-2.8.0.dylib 0x010a53ff wxBitmapRefData::UseAlpha?(bool) + 153 2 libwx_macud-2.8.0.dylib 0x010a5570 wxBitmap::UseAlpha?() + 28 3 libwx_macud-2.8.0.dylib 0x010b2b27 wxMemoryDC::DoSelect?(wxBitmap const&) + 167 4 _grass6_wxvdigit.so 0x0280e47b gwxPseudoDC::FindObjects?(int, int, int, wxColour const&) + 917 (pseudodc.cpp:528) 5 _grass6_wxvdigit.so 0x0281f088 _wrap_PseudoDC_FindObjects + 890 (grass6_wxvdigit_wrap.cpp:4700)

So it looks like this problem may be caused by some recent change in the local PseudoDC created for wxdigit.

Michael

comment:2 Changed 11 years ago by cmbarton

Further information. If you have a version of wxpython installed that does not match the one used for compilation, the digitizer does not load and the map elements are NOT frozen.

Michael

comment:3 Changed 11 years ago by cmbarton

Cc: kyngchaos added
Component: wxGUICompiling

This now seems to have something to do with compiling on a Mac, so I'm changing the component from wxGUI to compiling.

A workaround is to bundle wxPython inside the Mac app. So there is still a connection to wxPython, but it is not a GUI issue per se. The question remains as to why this works if wxPython is bundled in the app, but causes a serious crash if the same wxPython is not bundled.

Michael

comment:4 Changed 11 years ago by martin

Cc: martinl added; martin removed

I suspect martinl is the correct addressee for this stuff.

comment:5 Changed 11 years ago by cmbarton

Resolution: worksforme
Status: newclosed

I think this is due to a problem finding the correct wxpython. It may be specific to a few Macs where MacPython? is installed and not completely removed. It seems solved by completely removing a competing Python installation and reinstalling wxPython or by bundling wxpython with the binary. I'm marking it closed as 'worksforme' unless it crops up again under a different circumstance.

Note: See TracTickets for help on using tickets.