Opened 12 years ago

Closed 11 years ago

#74 closed defect (worksforme)

Tcl version of v.digit's background colour doesn't work

Reported by: craigleat Owned by: grass-dev@…
Priority: minor Milestone: 6.4.0
Component: Default Version: svn-trunk
Keywords: v.digit, Tcl Cc: glynn@…, hamish_b@…
CPU: Unspecified Platform: Unspecified

Description

It appears that the v.digit option: settings -> Symbology -> Background is broken, because I am unable to change the background colour. A further annoyance is that the background colour changes from white to cyan whenever a background vector is added. If a raster is added the background stays white.

Tested with Spearfish.

Change History (12)

comment:1 Changed 12 years ago by hamish

Keywords: Tcl added
Summary: v.digit option to set background colour doesn't workTcl version of v.digit's background colour doesn't work

Confirmed.

It's not just vector backdrop maps which turn the background color cyan, "d.grid 5000" does it too.

Hamish

comment:2 Changed 12 years ago by hamish

raster maps do turn the background cyan if you use the -o overlay flag with d.rast.

Hamish

comment:3 Changed 12 years ago by neteler

Resolution: fixed
Status: newclosed

Fixed by Glynn with r30805. Also backported to 6.3.0-relbranch.

comment:4 Changed 12 years ago by hamish

Resolution: fixed
Status: closedreopened

Glynn:

I think I've fixed this with r30805.

The background color is now white, but changing the background color from the Setting window Symbology tab (1st item) still doesn't work as expected.

With r30810 (just committed) it now respects the bg color, but only if you add a background command like 'd.grid 5000'. I also notice that you can't turn off background commands once created, unchecking their tick boxes has no visible effect, once rendered. (if not yet rendered it won't draw it if unticked) To make the bg cmd go away you need to fully delete the command text. (putting a # at the start of the line could work too? but not well)

Hamish

comment:5 Changed 12 years ago by hamish

Milestone: 6.3.06.4.0

comment:6 Changed 11 years ago by cmbarton

Cc: hamish_nospam@… added
CPU: Unspecified
Platform: Unspecified
Resolution: worksforme
Status: reopenedclosed

I've just tested in 15-08-08 SVN develbranch_6. All of these problems seem to be fixed, at least in the Mac version. I have some odd mouse behavior (middle-click acting like right-click), but that could be a function of using TclTk? 8.5 aqua. Could you please check and see if we can close this?

comment:7 Changed 11 years ago by craigleat

Cc: hamish_nospam@… removed
Resolution: worksforme
Status: closedreopened

Hamish:

it now respects the bg color, but only if you add a background command like 'd.grid 5000'

Agreed. The bg colour reverts to white if the bg command is disabled/removed.

Hamish:

I also notice that you can't turn off background commands once created

No, the toggle button works for me. Prefixing the command with a # also works.

Michael:

I have some odd mouse behavior (middle-click acting like right-click)

My mouse clicks work as expected.

Tested with GRASS 6.4 revision 32853 of 18 Aug 2008, Ubuntu 7.10 and Tcl 8.4.

Craig

comment:8 in reply to:  7 Changed 11 years ago by hamish

Replying to craigleat:

Hamish:

I also notice that you can't turn off background commands once created

craigleat:

No, the toggle button works for me. Prefixing the command with a # also works.

s/turn off/remove/

Hamish

comment:9 Changed 11 years ago by cmbarton

Cc: glynn@… added

I don't understand the 's/turn off/remove/'

I just checked again. I have no problem with the background color settings on my Mac with the current GRASS 6.4 compiled from the SVN develbranch_6. The vector itself is in the first "background", but that shouldn't be turned off of course. Glynn revamped the code so as to use a TclTk? canvas instead of an xwin. Maybe he can look at this too. It seems OK to me though.

Michael

comment:10 Changed 11 years ago by craigleat

Michael:

I have no problem with the background color settings on my Mac

A TclTk? bug perhaps? I have the problem with TclTk? 8.4, but it works for Michael who is using TclTk? 8.5.

Craig

PS This is a minor bug, maybe we just live with it and add a note to the manual page.

comment:11 Changed 11 years ago by glynn

In r32876, the canvas' background colour is updated whenever the background setting changes.

comment:12 Changed 11 years ago by craigleat

Cc: hamish_b@… added
Resolution: worksforme
Status: reopenedclosed

Well done Glynn and thanks. It works correctly now (for me at least). I'll allow Hamish to test further and resolve as 'fixed'.

Note: See TracTickets for help on using tickets.