Opened 10 years ago

Closed 10 years ago

#732 closed defect (duplicate)

Warming message after removing layer confusing

Reported by: pvanbosgeo Owned by: grass-dev@…
Priority: normal Milestone: 6.4.0
Component: Default Version: svn-develbranch6
Keywords: remove, delete, message Cc:
CPU: x86-64 Platform: Linux

Description

I am not sure this is a bug or I am just not following the logic of the message, but:

suppose I have both in mapset 'climate' and 'climpred' a layer prec_8. When deleting the layer 'prec_8' from mapset 'climpred' I get the following message:

quote> Removing raster <prec_an> cell/prec_8' was found in more mapsets (also found in <climpred>) Using <prec_an@climate> <unquoute

For me this is confusing as it seems to tell that the layer prec_8 is deleted from the wrong mapset (which is not the case). If the message is correct, would it mean that after deleting the layer subsequent actions using layer prec_8 will take that layer from the mapset climate?? If so I would suggest to rewrite that message to something like:

quote> Another laye with the name prec_8 exists in mapset <climate> Removed prec_8@climpred <quote

Such a message would be more in line with the (rather straightforward and clear) message one gets when using a layer in r.mapcalc while a layer with the same name exists in another mapset.

Paulo

Change History (1)

comment:1 Changed 10 years ago by hamish

Resolution: duplicate
Status: newclosed

dupe of #731

Note: See TracTickets for help on using tickets.