Opened 10 years ago

Closed 10 years ago

#711 closed defect (fixed)

r.horizon crashes

Reported by: eblizza Owned by: grass-dev@…
Priority: normal Milestone: 6.4.0
Component: Raster Version: 6.4.0 RCs
Keywords: r.horizon, wingrass Cc:
CPU: x86-32 Platform: MSWindows XP

Description

Hello,

r.horizon terminates after going through a series of matching files past kernel32.dll that ends with </DATABASE>.

I realize that you are busy, but could you consider fixing this as a change of pace? I spoke with an ESRI user at MORAP (www.cerc.usgs.gov/morap/) who needs similar output. If r.horizon worked, then they might expand to become GRASS users as well.

Alternatively, would you please tell me how to get horizon angles for a point using ARCMap?

Thank you,

Elizabeth

Attachments (1)

r.horizon_da8a_appcompat.txt (134.8 KB) - added by eblizza 10 years ago.
Microsoft error log

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by eblizza

Microsoft error log

comment:1 Changed 10 years ago by neteler

CPU: Unspecifiedx86-32

Please specify in which projection you used r.horizon and with which parameters. We need to be able to reproduce the problem...

Markus

comment:2 Changed 10 years ago by hamish

Component: defaultRaster
Keywords: wingrass added
Priority: blockernormal

comment:3 Changed 10 years ago by hamish

n.b. like #736, r.horizon uses pj_*() functions. maybe a clue there.

Hamish

comment:4 in reply to:  3 ; Changed 10 years ago by neteler

Replying to hamish:

n.b. like #736, r.horizon uses pj_*() functions. maybe a clue there.

Since #736 has been fixed, is r.horizon now working on winGRASS? The manual page contains a test example. Can this be closed?

Markus

comment:5 in reply to:  4 Changed 10 years ago by hellik

Replying to neteler:

Replying to hamish:

n.b. like #736, r.horizon uses pj_*() functions. maybe a clue there.

Since #736 has been fixed, is r.horizon now working on winGRASS? The manual page contains a test example. Can this be closed?

Markus

tested with a self compiled actual Grass64 on WinVista32:

r.horizon elevin=dtm@PERMANENT direction=15 horizonstep=30 bufferzone=200 maxdistance=200 horizon=horangle [...] (Sun Mar 07 21:35:07 2010) Command finished (196 sec) - while r.sunmask is working in the background

Helmut

comment:6 Changed 10 years ago by neteler

Resolution: fixed
Status: newclosed

As it is working now, I am closing. Feel free to reopen if the problem persists.

Note: See TracTickets for help on using tickets.