Opened 11 years ago

Closed 10 years ago

#685 closed defect (fixed)

make htmldocs fails with "cannot stat `gisliblib.dox': No such file or directory"

Reported by: mlennert Owned by: grass-dev@…
Priority: normal Milestone: 7.0.0
Component: Compiling Version: svn-trunk
Keywords: doxygen lib/gis Makefile Cc: martinl
CPU: Unspecified Platform: Unspecified

Description

Running make htmldocs fails as follows:

Generating file member index...
HTML reference in directory ./html/index.html
make[1]: Leaving directory `/home/mlennert/SRC/GRASS/grass_trunk/lib/g3d'
(cd lib/gis/ ; make cleandocs ; make htmldocs)
make[1]: Entering directory `/home/mlennert/SRC/GRASS/grass_trunk/lib/gis'
rm -rf ./latex ./html
make[1]: Leaving directory `/home/mlennert/SRC/GRASS/grass_trunk/lib/gis'
make[1]: Entering directory `/home/mlennert/SRC/GRASS/grass_trunk/lib/gis'
rm -rf ./latex ./html
mv: cannot stat `gisliblib.dox': No such file or directory
make[1]: *** [htmldocs] Error 1
make[1]: Leaving directory `/home/mlennert/SRC/GRASS/grass_trunk/lib/gis'
make: *** [htmldocs] Error 2

This is due to a change introduced in r38003 in trunk:

(in lib/gis/Makefile) -DOXNAME=gis +DOXNAME=gislib

Is there any reason for this change ?

Moritz

Change History (4)

comment:1 in reply to:  description ; Changed 11 years ago by martinl

Replying to mlennert:

(in lib/gis/Makefile) -DOXNAME=gis +DOXNAME=gislib Is there any reason for this change ?

To standardize the naming conventions, see rasterlib, vectorlib, etc.

I cannot reproduce this error, works for me.

Martin

comment:2 in reply to:  1 ; Changed 11 years ago by mmetz

Replying to martinl:

Replying to mlennert:

(in lib/gis/Makefile) -DOXNAME=gis +DOXNAME=gislib Is there any reason for this change ?

To standardize the naming conventions, see rasterlib, vectorlib, etc.

But then it should suffice to have gislib.dox and

DOXNAME = gis

same in lib/raster

see lib/dbmi or lib/display or lib/vector

Same error here, disappeared after removing the lib part from the DOXNAME.

Markus M

comment:3 in reply to:  2 Changed 11 years ago by martinl

Replying to mmetz:

But then it should suffice to have gislib.dox and

DOXNAME = gis

same in lib/raster

see lib/dbmi or lib/display or lib/vector

Done in r38421.

Same error here, disappeared after removing the lib part from the DOXNAME.

Strange, works also with "lib" here.

Martin

comment:4 Changed 10 years ago by neteler

Resolution: fixed
Status: newclosed

Seems to be solved, closing.

Note: See TracTickets for help on using tickets.