Opened 11 years ago

Closed 10 years ago

#593 closed defect (fixed)

WinGRASS GIS.m: cannot select maps from mapset GUI

Reported by: hamish Owned by: marisn
Priority: critical Milestone: 6.4.0
Component: Tcl/Tk Version: 6.4.0 RCs
Keywords: wingrass gis.m Cc: grass-dev@…, maris.gis@…
CPU: x86-32 Platform: MSWindows XP

Description

Hi,

GIS.m on wingrass refuses to let you select maps from another mapset.

e.g. spearfish, from the user1 mapset:

  • start gis.m
  • click the button to add a new raster map
  • click the button at the left of the map name entry box to open the map list GUI
  • only the user1 folder is open, the PERMANENT folder will not open.
  • type elevation.dem@PERMANENT by hand and it works.

?, Hamish

Change History (21)

comment:1 Changed 10 years ago by hamish

ah, the little [+] [-] boxes to expand the folders are missing on wingrass for some reason. so the PERMANENT folder stays permanently closed.

comment:2 Changed 10 years ago by hamish

Summary: WinGRASS GIS.m: cannot select maps from other mapsetsWinGRASS GIS.m: cannot select maps from mapset GUI

you can't select maps from the current mapset either. see #637

comment:3 Changed 10 years ago by marisn

Owner: changed from grass-dev@… to marisn
Status: newassigned

I hope I have fixed this issue in 6.5. r38295

Please test it on Linuxes, Macs and Windblows. If OK, needs to be merged into 6.4.0.

comment:4 Changed 10 years ago by hamish

Thanks a lot Maris! Fingers crossed..

I am not well set up for building WinGRASS or even dropping in new tcl files. If someone who is can test 6.5svn and report back please.... ?

Picking a map in gis.m still seems to work ok work on Linux.

cheers, Hamish

comment:5 in reply to:  4 ; Changed 10 years ago by hellik

Resolution: fixed
Status: assignedclosed

Replying to hamish:

Thanks a lot Maris! Fingers crossed..

I am not well set up for building WinGRASS or even dropping in new tcl files. If someone who is can test 6.5svn and report back please.... ?

Picking a map in gis.m still seems to work ok work on Linux.

cheers, Hamish

hi

grass65-svn compiled (in osgeow4-tree) at rev38296

now it's possible to select raster and vector in the tcltk-gui. so the ticket should be closed.

all the best Helli

comment:6 Changed 10 years ago by hamish

In 6.5svn r38310 I set MAPSET back to a normal string -- it's not a multipart path name. It seemed odd/wrong to add "pwd/" to it then strip it away again a few lines later.

also in select.tcl line 180,

source:grass/branches/develbranch_6/lib/gtcltk/select.tcl@38310#L180

should $path be "quoted"?

Hamish

comment:7 in reply to:  5 Changed 10 years ago by hamish

Replying to hellik:

grass65-svn compiled (in osgeow4-tree) at rev38296 now it's possible to select raster and vector in the tcltk-gui.

can you select a different vector points symbol (say something from the geology folder) and display it correctly?

Hamish

comment:8 Changed 10 years ago by hamish

Resolution: fixed
Status: closedreopened

comment:9 Changed 10 years ago by hamish

Cc: grass-dev@… added

comment:10 Changed 10 years ago by hamish

(leave open until everything is backported & job is done)

comment:11 Changed 10 years ago by marisn

Thanks Hamish for spotting my oversight with mapset.

$path in select.tcl seems to work just fine without quotes (no idea why - must be something of tcl beloved lists vs strings), still there was another issue with running anything if GISBASE contains spaces. Fixed in r38311. Also an candidate for 6.4.0.

Leaving open till it's tested and backported.

comment:12 Changed 10 years ago by cmbarton

Works fine in GRASS 6.4 and 6.5 svn on Mac OS X.

Michael

comment:13 in reply to:  12 Changed 10 years ago by hamish

Replying to cmbarton:

Works fine in GRASS 6.4 and 6.5 svn on Mac OS X.

yeah, it's only on WinGrass. I think Maris committed a fix for this in 6.5svn, but it awaits review & backporting by someone who understands Tcl better than I do.

Hamish

comment:14 Changed 10 years ago by cmbarton

Cc: maris.gis@… added

I can't test this on windows unless I have a binary to give to one of my students who uses windows. I've been out of the loop for awhile. But if Maris can give me the fix, I can manually insert it into a 6.4 Windows binary and see if it works.

Michael

comment:15 Changed 10 years ago by hellik

grass65 selfcompiled in the osgeo4w-stack on WinVista32 rev39115 nc-dataset mapset: user1

there's no problem to choose a vector or raster from another mapset like PERMANENT in the nc-dataset. i've tried this with spaces (C:\gis data\grassdata) and without spaces (C:\gisdata\grassdata) in the path to the location.

comment:16 in reply to:  15 Changed 10 years ago by hellik

Replying to hellik:

grass65 selfcompiled in the osgeo4w-stack on WinVista32 rev39115 nc-dataset mapset: user1

there's no problem to choose a vector or raster from another mapset like PERMANENT in the nc-dataset. i've tried this with spaces (C:\gis data\grassdata) and without spaces (C:\gisdata\grassdata) in the path to the location.

tested in the tcltk/gis.m GUI

comment:17 Changed 10 years ago by cmbarton

Is this relevant anymore? If the problem is

1) with the TclTk? GUI and not wxpython, 2) only in Windows, and 3) if wxpython is the default GUI for WinGRASS 6.4,

do we need to worry about it?

Michael

comment:18 in reply to:  17 Changed 10 years ago by hamish

Replying to cmbarton:

Is this relevant anymore?

To me, yes. Others are of course free to decide that for themselves and spend their time worrying about issues they find more interesting, as they like.

bugs we know about should be fixed. especially ones that cripple an entire subsystem. anyway, this is just a small backport, not a huge investment in/redirection of effort. The larger problem on spaces in path names is of course another matter. I'm still a bit frustrated that the MSys devs won't even take patches for this class of bug.

I would also note that making things more robust on WinGrass typically has the byproduct of making thinks slightly more robust on other platforms as well.

Hamish

comment:19 Changed 10 years ago by cmbarton

If it's just a backport, I'm definitely in favor doing this.

Like I said, I can probably stick a TclTk? patch into a student's 6.4 Windows binary to test this if it is a help. To do this on Windows, however, it will be much easier if I get the entire patched tcltk module instead of a patch file.

Michael

comment:20 Changed 10 years ago by marisn

Please test r39149.

comment:21 Changed 10 years ago by hamish

Resolution: fixed
Status: reopenedclosed

tested in latest WinGrass 6.4 installer (WinGRASS-6.4.0SVN-r39271-1-Setup.exe).

works; closing bug.

(it complains that it can't find the fontcap file though)

thanks, Hamish

Note: See TracTickets for help on using tickets.