Opened 11 years ago

Closed 11 years ago

#569 closed defect (invalid)

v.label.sa compilation error due to freetype

Reported by: neuba Owned by: grass-dev@…
Priority: normal Milestone: 7.0.0
Component: Vector Version: svn-trunk
Keywords: Cc:
CPU: x86-32 Platform: Linux

Description (last modified by neteler)

I got this error in grass 6.5 svn and their is the following error, in the v.label.sa directory:

gcc -I/home/danho/gis_soft/grass6_devel/dist.i686-pc-linux-gnu/include  -g -O2    -I/usr/include/gdal/    -DPACKAGE=\""grassmods"\"   -I/home/danho/gis_soft/grass6_devel/dist.i686-pc-linux-gnu/include -o OBJ.i686-pc-linux-gnu/annealing.o -c annealing.c
Dans le fichier inclus à partir de annealing.c:15:
labels.h:20:22: erreur: ft2build.h : Aucun fichier ou dossier de ce type
labels.h:21:10: erreur: #include attend "NOM_DE_FICHIER" ou <NOM_DE_FICHIER>
labels.h:22:10: erreur: #include attend "NOM_DE_FICHIER" ou <NOM_DE_FICHIER>
make: *** [OBJ.i686-pc-linux-gnu/annealing.o] Erreur 1

Change History (6)

comment:1 in reply to:  description Changed 11 years ago by glynn

Replying to neuba:

I got this error in grass 6.5 svn and their is the following error, in the v.label.sa directory:

A couple of notes about submitting bug reports:

  1. All build output should be in the C locale; use e.g. "LC_ALL=C make ..." when compiling. Output from running GRASS programs should be in the C locale unless the report specifically relates to a localisation issue, or if you need to post the original text because you can't reproduce the error.
  1. Any blocks of literal text, e.g. program output, should be enclosed in triple braces to preserve formatting; see the WikiFormatting link above the comment box for details.

comment:2 Changed 11 years ago by neteler

Description: modified (diff)

comment:3 Changed 11 years ago by neteler

Resolution: invalid
Status: newclosed

You need to install the freetype6-devel package or indicate it properly:

# e.g., Mandriva:
./configure --with-freetype --with-freetype-includes=/usr/include/freetype2 ...

Feel free to reopen if you have done above and it still fails.

comment:4 Changed 11 years ago by neuba

Resolution: invalid
Status: closedreopened

I made all the thingyou did in fedora 10 but there is still the same problem. I is also the same thing in grass70 because of freetype

comment:5 Changed 11 years ago by neteler

Component: defaultVector
Milestone: 6.5.07.0.0
Summary: grass compilation error due to freetypev.label.sa compilation error due to freetype

(title renamed to more useful title)

Ok, reproduced:

labels.c: In function ‘labels_init’:
labels.c:86: error: implicit declaration of function
‘find_font_from_freetypecap’
labels.c:98: error: implicit declaration of function ‘free_freetypecap’
make: *** [OBJ.x86_64-unknown-linux-gnu/labels.o] Error 1

because of r34923 - the module needs to be updated accordingly.

comment:6 Changed 11 years ago by neuba

Resolution: invalid
Status: reopenedclosed

I resolve the problem. I modified annealing.c and i left a small syntax error in the code. Please apologize me.

Note: See TracTickets for help on using tickets.