Opened 11 years ago

Closed 11 years ago

#535 closed enhancement (fixed)

toolbar "add vector" and "add raster" buttons have a regression in usability from gis.m

Reported by: steko Owned by: martinl
Priority: major Milestone: 6.4.0
Component: wxGUI Version: 6.4.0 RCs
Keywords: Cc: grass-dev@…
CPU: All Platform: All

Description

In gis.m, the "add vector" and "add raster" commands had a single dedicated button, and it would seem natural that such fundamental operations are 1 click away from the user.

The new wxGUI, instead, forces the user to click 2 more times:

  1. click the "add vector map layer" button
  2. choose the "add vector map layer" option
  3. the d.vect window opens
  4. the user has to click AGAIN to see the layers' list and eventually select the desired map

This looks like a serious usability regression IMHO.

Change History (2)

comment:1 Changed 11 years ago by martinl

Cc: grass-dev@… added
Owner: changed from grass-dev@… to martinl
Status: newassigned

Agreed, changed in r36926 (devbr6), r36927 (trunk) and r36928 (relbr64).

Martin

comment:2 Changed 11 years ago by martinl

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.